[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: knoppix HD-install problem

Sorry to reopen an old thread but I need help on a tough problem (at least for me, though not a complete newbie I have a limited knowledge of the Linux world) which has Knoppix at its origin (though now it probably is not related to Knoppix any more) and I couldn't find a more pertinent thread. Also, since this is my first participation to a technical mailing list and I may occasionally experience language difficulties, please bear with me.

To begin in the beginning... (I'll give you the macro facts first, the technical data will follow as soon as you ask for them, hopefully I'll manage to follow your indications, I wouldn't know where to start now).

I own an Acer Aspire 1524WLMi laptop (AMD Athlon 64 CPU, NVIDIA GeForce FX Go 5700 64MB, 512MB DDR RAM, ...) with Windows XP SP2 preinstalled. A few months ago I downloaded from an Italian mirror an Italianized version of Knoppix 3.6, called EduKnoppix-2.0.94-kids, because I wanted to get acquainted with GNU/Linux and to enjoy the richness of the didactic packages offered by that distribution. Everything went fine, double boot included, and I lived happily ever after... (hard problems with Winmodem & USB mouse notwithstanding).

Until... I tried to install a package for the management of spatial data (grass-6.0.0.tar.gz) and started having problems (libraries not present, to say the least). So I decided to go Debian unstable. After a brief - too brief? - research I opted for the apt-get mechanism (apt-get update & apt-get dist-upgrade; my /etc/apt/sources.list set on "unstable"; "stable" and "testing" only for security updates). Over a slow modem 56Kbps connection it took quite a long time (24hrs+). After reboot, the X server was a bit unstable, KDE and the mouse and touchpad were gone, most of the Knoppix packages too, and I was left with the sensation that not every "unstable" package had been properly downloaded and installed (some error messages warned that a few problems had occurred). So I "apted" once more; plus, I wanted to try GNOME (apt-get install gnome & various other packages; more trouble reconfiguring ppp with the internal Winmodem in the meantime, since kppp was gone as well). Went ahead (another 24 hrs or so) and on reboot nothing much had changed (a few more packages & applications were there - such as Mozilla and a tiny bit of Gnome - but most of them unusable; also, I kept getting annoying messages in the system log from services that had apparently been installed without explicit consent, such as brltty, bind, bacula, nis and so on). I probably had been too hasty in beginning the apt download without managing important aspects I didn't know - and should have known - existed.

Anyway, I decided to be more scientific about my Debian download; my personal data on Linux were still there, so nothing irreparable seemed to have occurred. I discovered the dselect utility for the dpkg management and felt quite happy to be able to control and finely tune my installation, all the time being guided hand by hand through the harsh maze of package dependencies. After 24 more hrs of slow downloads, while I was through the installation chapter of dselect, I was warned by a particularly menacing message that the 2.4.27 version of the kernel I had been running so far would have been removed, and, among other things, that I would not have been able to reboot the system. I wasn't willing to take the risk, particularly since I hadn't meant to switch to kernel 2.6 in the first place. So I got back to the package selection step, and unselected the kernel removal option. Back to downloading the 2.4.27 kernel, I felt I was close to the end of my odyssey; I interrupted my connection to the internet, I had to go and collect my children at school. Once I later tried to resume my connection to finish the download, I found out many things had changed in the meantime in my configuration; above all, wvdial was no longer there, nor the slmodem daemon I had used so far. Taken aback, I rebooted, hoping for the best, and swearing to myself I would never get in such troubles again...

Luckily, I managed to reboot, the boot loader and the 2.4.27 kernel were still there; but other things had disappeared; amog them, the slamr module for the soft modem connection. So I downloaded the slmodem-2.9.10.tar.gz package again, but there was no way I could manage to install it.

Now, to make a long story short, I'm stuck. Also I would like to proceed as it should be done, not by wild guesses which could probably make matters even worse. Also I would like to keep my Deb packages if possible, without reinstalling Knoppix, not only out of respect for a long 4 days work, but especially out of curiosity for Debian (and I have GRASS as one of my chosen packages in dselect, too)!

Please, if any one out there feels there is still hope for a tentative debianite on the lake of Bracciano (50 km from Rome), please let me know and I will be forever grateful.

Reply to: