[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: S3 Vision964-Graficcard: Installation of Xfree 3.3.6 on Sarge



On 5/4/05, Walther, Christoph <Christoph.Walther@t-systems.com> wrote:
>  
> 
> Dear Debian-user-list, 
> 
> because of the fact, read on
> www.xfree86.org/4.3.0/Status29.html :
>  
> **************************************************************************************
> "Summary: 
> 
> All hardware supported in 3.3.6 is also supported in 4.3.0 except for the 
> 911, 924, 801, 805, 928, 864, and 868, and versions of the 964 and 968 
> that do not use the RAMDAC chips listed above. The SuperSavage chipset 
>  is supported only in 4.3.0." 
> **************************************************************************************
> 
> my elderly graficcard, S3 Inc. 86c964 [Vision 964 VRAM] doesn't work with
> the delivered 
> XFree86 Version 4.3.0 on Sarge. 
> -> only vesa-mode, RAMDAC-chips are not supported here. 
> 
> Meanwhile, the XFree86 3.3.6-Version is further available. 
> 
> Can anyone tell me, 
> 
> 1) from where get the Xfree 3.3.6 as Debian-paket, complete with dependig 
>    other pakets (e.g. libraries, etc.) 
> 
> and 
> 
> 2) how to install/configure it easy-going step by step on Sarge without 
>    mismatch with Xfree 4.3.0 and system to get S3 86c964-card running ? 
> 
> I suppose, that would be the correct way, to configure my S3 86c964-card on
> the Sarge-System ... 

You'd have to live with XFree 4.3, and for this good reason (from the
Debian X FAQ):

"What is the story with XFree86 3.x?

As of September 2003, packages of XFree86 3.x are no longer supported
by the Debian Project. Please note that the XFree86 3.x codebase is
not maintained by anyone, even for security fixes. If you run XFree86
3.x on your system, you may be vulnerable to CAN-2002-0164,
CAN-2003-0063, CAN-2003-0071, CAN-2003-0690, CAN-2003-0730,
CAN-2004-0083, CAN-2004-0084, CAN-2004-0093, CAN-2004-0094,
CAN-2004-0106, CAN-2004-0687, and CAN-2004-0688 (as indexed by the
MITRE CVE project), among other flaws.

Version 3.x XFree86 X server packages include: xserver-3dlabs,
xserver-8514, xserver-agx, xserver-fbdev, xserver-i128,
xserver-mach32, xserver-mach64, xserver-mach8, xserver-mono,
xserver-p9000, xserver-s3, xserver-s3v, xserver-svga, xserver-tga,
xserver-vga16, xserver-w32, xserver-xsun, xserver-xsun24, and
xserver-xsunmono.

If XFree86 3.x works on your hardware, but XFree86 4.x and the X.Org X
server do not, the Debian Project could use your help in getting the
more modern X server code to support your hardware. The best place to
start is with a bug report!"

-- 
Paolo Alexis Falcone
pfalcone@gmail.com



Reply to: