[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Postfix + SASL problem "no SASL authentication mechanisms"

Lech Karol Pawłaszek wrote, on 04/22/05 16:46:
On Friday 22 of April 2005 16:56, Cliff Flood wrote:

"no SASL authentication mechanisms" error.


Could someone tell me more specifically what the error is indicating?

At this point I'm rather confused and annoyed and I'd appreciate any
help any one can give me!

I grant that you're using sarge... i think that you've installed most of needed packages like postfix-tls and sasl2-bin, so...
Check if you have libsasl2-modules package installed.

Thanks :)

You're welcome ;-]

Great! Thank you! That worked, I didn't have that package installed and now that I do I am no longer getting that error.

I am now getting another error however...

"warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: Permission denied"

In my /etc/postfix/sasl/smtpd.conf I have tried:

pwcheck_method: saslauthd


pwcheck_method: pwcheck

(Having first installed cyrus-common to provide pwcheck)

I want saslauthd to use pam to authenticate users against their regular passwords, not to use a second database.

Where am I going wrong?


Reply to: