[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Aspell 0.60 and mutt - Answer and (SOLVED) And the reason

Wayne Topa(linuxone@intergate.com) is reported to have said:
> Allan Wind(allan_wind@lifeintegrity.com) is reported to have said:
> > On 2005-04-04T18:32:04-0400, Wayne Topa wrote:
> > > Oh, do I wish it were that simple.... Made the change, as you show and
> > > 
> > > VT5 wtopa-Buddy:~$ mutt
> > > Error in /home/wtopa/.muttrc, line 62: ispell=aspell -e -c: unknown command
> > 
> > Can you paste what you have in .muttrc?  Sounds like you did not quote
> > ("") the right side.  Here is what I have:
> > 
> > set ispell="aspell -e -c"
> > 
> > seem to work, but I do not use the feature.
> I did quote, all of what I tried, in the original post.
> from my .muttrc
> ### Test this macro  (Didn't work?)
> #macro compose i \
> #"<filter-entry>newsbody -hqs -n - -p aspell check %f<enter>" \
> #"run aspell on the select part"
> set ispell="aspell -e -c"
> # aspell works better with email   (Didn't work?)
> #set ispell='aspell \
> #   --language-tag=`echo $LANG|sed "s/\.[^.]*$//"` \
> #   --encoding=`echo $LANG|sed "s/^[^.]*\.\?//"` \
> #   --mode=email \
> #   --add-email-quote=%,#,:,} \
> #   --check'
> Wayne
> Interesting  I just hit 'i' in the compose screen and it does,
> now, indeed bring up aspell.  Somethis is real fishy here.  I worked
> on this problem for 4 1/2 hrs yesterday, always restarting mutt
> between changes, and now it doeds work!
> it = set ispell="aspell -e -c"

I have found out what the problen was.
As I have just changed ISP's, and I now have 4 different email
addresses, I revamped my muttrc.  I had to put in so many folder-hooks
I decided to make is a seperate file.  ie
##------------- Debian-user
subscribe debian-user@lists.debian.org
folder-hook debian-user unmy_hdr reply-to from Organization
folder-hook debian-user my_hdr Reply-To: 'debian-user@lists.debian.org '
folder-hook debian-user my_hdr From: 'linuxone@intergate.com'
folder-hook debian-user my_hdr Organization: 'Organized? Who me?'
send-hook debian-user "set signature='~/bin/randsigs.pl|'"

##------------- Debian-firewall
subscribe debian-firewall@lists.debian.org
folder-hook debian-firewall unmy_hdr reply-to from Organization
folder-hook debian-firewall my_hdr Reply-To: 'debian-firewall@lists.debian.org '
folder-hook debian-firewall my_hdr From: 'linuxone@intergate.com'
folder-hook debian-firewall my_hdr Organization: 'Organized? Who me?'
send-hook debian-firewall "set signature='~/bin/randsigs.pl|'"

When I was testing the aspell, I was working in a mailbox I call admin.
When I replied to Allan I as in the debian-user mbox and it worked 
but when I went back to check in the admin mbox it didn't.  In fact 
if I try to use aspell in any mbox that is not in my folder-hook file,
aspell doesn't work.  So I added this

##-------------------- Admin
folder-hook admin unmy_hdr replyto from organization
folder-hook admin my_hdr From: 'huntbrittany@intergate.com'
folder-hook admin my_hdr Reply-To: 'huntbrittany@yahoogroups.com '
folder-hook admin my_hdr Organization: 'Patway Brittanys'

And aspell now works in the admin mbox, but not in others that I don't
have the folder-hook, like the above, set up.

It might be the position of where I source the folder-hooks or lists 
or mailboxes but I have yet to test that theory.

Now back to trying the other setups I tested (in the admin mbox),
to see if I can get them working.

Thanks to all for their comments.  The kick's, :-) , worked and now, 
so does aspell.

Is reading in the bathroom considered Multi-Tasking.

Reply to: