[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mouse and Belkin Omnicube not happy

Just thought I put this log statement out, in case someone recognises it:

Mar 17 21:10:55 gondor kernel: psmouse.c: Explorer Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.g

That's what I see when I switch back to my debian machine. I have to unplug the mouse and plug it back in again to get it to work again.

On 17/03/05 20:39 Adam Hardy wrote:
just had a thought. When you had the same problem with your Belkin, do you know whether it was 'hotplugging'?

At the moment I'm banking on it being because of the hotplugging messing up what the Belkin switcher does.

Plus of course I can't work out why my mouse still seems to be hotplugging despite thinking I had disabled hotplugging on it.


On 17/03/05 02:54 tony mollica wrote:

I had a similar problem with a new install of Debian testing where
the mouse would not 'synchronize' when switched away from that
particular box and the back again.  I took a chance and purchased a
new KVM switch, Belkin F1DJ104P 4-port, hoping that a newer switch
would have better mouse emulation than my old Protec KVM purchased
many years ago.  It did and it now works fine.  The new switch did
the trick.  Might be worth it to try a newer or different switch.

Adam Hardy wrote:

Hi All

I just upgraded from RH9 to Debian with relative ease, although I
am still ironing out a couple of wrinkles! :)

I've got 3 computers set up to share a monitor, mouse and keybd via
a Belkin Omnicube. When I switch back to debian, the mouse loses
its grip on sanity. If I pull the mouse cable out of the socket and
 replace it, then the mouse regains its composure.

I get some lost synchronisation 3 bytes etc etc error message on
the console when I move the mouse, although I haven't worked out
how to capture the log to quote it here.

Googling dug up a email about a similar problem, but with Murphy's
Law in action, there was no solution. Apparently it may have
something to do with hotplug.

I tried to deconfigure hotplug for the mouse, but failed. I thought
if I put 'psmouse' into /etc/hotplug/blacklist, then hotplug
wouldn't interfere. However it seems hotplug is still operating on
the mouse even with that module quoted in blacklist.

Any suggestions, anyone? (config below)

Thanks Adam

PS tried it with gpm too with no luck

from XF86Config: Section "InputDevice" Identifier    "Configured
Mouse" Driver        "mouse" Option        "CorePointer" Option
"Device"        "/dev/input/mice" Option        "Protocol"
"ImPS/2" Option        "Emulate3Buttons"    "true" Option
"ZAxisMapping"        "4 5" EndSection

from console: gondor:/home/adam# lsmod |grep mouse psmouse
27528  0

ant 1.6.0 + java 1.4.2 on Linux 2.4.20 Debian

Reply to: