[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB cd burning in 2.6.8-2

> From: David Hugh-Jones <davidhughjones@gmail.com>
> Date: Today 07:38:14
> Hi all
> I've just tried to burn a CD for the first time in a few months. 
>This used to go like mkisofs blah blah blah followed by cdrecord 
>-scanbus to find out the device number for my USB cd-writer, and 
> then cdrecord blah blah blah Now, for some reason, I have to do 
> modprobe sg before I run cdrecord.   
> Anyone know why sg isn't getting automatically modprobed when my 
> cdrom is plugged in? Can I fix it? 
> David

What does scanbus say, does it give you ATA ATAPI or the regular 0,0,0 
or some such. I also know that their is a kernel header bug for the 
2.6.8, 2.6.9 kernel's with some external USB cdrw's, dvd burners.  

For instance I have a Nec 3500A in an external case and I can not use 
the 2.6.8 or 2.6.9 kernels, 2.6.7 works great, supposed to be fixed 
in the 2.6.10 release, but have not updated my kernel yet. Also what 
kernel are you using, if your using the 2.4 series then I can see sg 
being needed, but the 2.6 series should not require the old SCSI 
software, and should work with the ATA, or the ATAPI in the device 

Also when you first load your kernel, what does lsmod show, does it 
show the needed module as loaded, maybe you forgot to configure it as 
loadable the last time you updated your kernel. 


Reply to: