[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [OT] realtek network card: how to find why card won't sync at 100Mbps against anything

On Wed, 26 Jan 2005 21:11:22 -0600
Jacob S <stormspotter@6Texans.net> wrote:

> On Thu, 27 Jan 2005 01:17:06 +0200
> Micha Feigin <michf@post.tau.ac.il> wrote:
> > I have a problem for some time now with my laptops on board realtek
> > 8139 network card. It works properly when locked into 10 Mbps mode but
> > when set to negotiate connection it doesn't sync.
> > 
> > mii-tool and mii-diag show that it reads the partners abilities
> > properly and negotiates 100Mbps connection but the link status remains
> > as unestablished. It seems that it negotiates 100Mbps correctly, sets
> > the card but then fails to communicate with the other machine and
> > start negotiation again. Setting the speed to 100Mbps manually doesn't
> > help either.
> > 
> > If I force the card to 10Mbps it works properly (although slowly).
> > 
> > Taking it to the shop will costs more then an external pcmcia or usb
> > network card and it works at 10Mbps now so its not worth taking to a
> > technician. I was if its possible and if there is a way to check if
> > its the internal cable connecting the card to the external port or if
> > the on board chip is blown. Can there be something only partially
> > wrong with the cable so that it will work at 10Mbps and not at
> > 100Mpbs?
> > 
> > It displayed the same behavior under windows (when I had it installed)
> > and on several versions of linux so it doesn't seem to be a software
> > bug. Could be firmware?
> I didn't see you mention trying this in your post, so I'll go ahead and
> mention it. Have you tried different ethernet cables? I had several
> computers behave like that when the wires weren't swapped properly. It
> was still a straight cable, but there seemed to be some crosstalk
> between the wires, causing 100Mbps to fail, but 10Mbps would work great.
> I have also seen a flaky network card in a Windows machine that would
> sometimes work when the cable was picked up just a little, forcing the
> nose of the connector down onto the connections. Or even pushed in a
> little harder - this was awful as you had to keep one hand on the cable
> all the time.
> Other than that, the only thing I could think of would be your driver.
> You don't mention what kernel version you're using. I would upgrade to
> at least 2.6.9. Which 8139 driver are you using? (In 2.6.7 I notice
> there is 8139cp and 8139too.)

I am using 2.6.11-rc2 with 8139too at the moment although it happened with
anything from somewhere around 2.6.5 or so and 2.4.24-2.4.27 and under windows,
so it doesn't seem to be the driver. It also stopped working at some point
without switching the kernel, so I believe its a hardware problem (unless some
hacker broke in and messed the card data, not sure if its firmware or something
else that its using, but highly unlikely in my opinion).

The two points of failure can be either the on board chip (although why it would
allow only 10Bps is beyond my current knowledge), or the cable that connects the
chip's connection on the motherboard to the external port (its a laptop).

I tried connecting it to several computers, hubs, residential gateways and cisco
switch with different cables with the same behavior, so if its the cable its the
internal one. I will try to call the local retailer and see if I can get an
internal cable off them cheep enough for it to be worth the shot.

Since its a laptop its very expensive to service and I can't replace the
on-board card although on the other hand pcmcia and usb adaptors are somewhat
cumbersome. Of course the trouble started AFTER it came back from the Sony labs
for what was supposed to be warranty work for a burned CPU which cost 250$
(before S&H) and I broke down trying to find why after 3 months of no
intelligent answer from their support /end rant (sorry for that, I'm never
buying Sony again though, same result with Sony France and Sony usa with
different equipment)

> HTH,
> Jacob
> -- 
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
>  +++++++++++++++++++++++++++++++++++++++++++
>  This Mail Was Scanned By Mail-seCure System
>  at the Tel-Aviv University CC.

Reply to: