[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

why cups so rarely works "out of the box"

Perhaps there is something basic that I have missed, but I do not
understand why cups fails to work when first installed in most cases.  I
have done this several times on various boxes now, and well over half 
the times, cups sends raw postscript to the printer.  Can anyone 
explain why the installation of bog-standard epson or hp printers 
should be so unreliable?  

Sometimes I have solved the problem with a few hours of work, googling
and trial-and-error.  Sometimes it takes months.  Occasionally it just
works.  But I have never identified the item that trips it up.  I
thought once it was not having cups-bsd.  Another time it might have
been foomatic database (I forget the exact package name). I have tried
-- and abandoned -- writing my own ppd files (though that should not be
necessary for an epson c62 or c64, surely). Someone else said remove
xprint, and once that seemed to work.  Eventually it always starts
working, usually after a reboot occasioned by something else.  And I
never really know what I did to get it working.

So here I am, stuck again with a sid install on a slow old thinkpad 570
and an epson c62 printing postscript by the ream.  I do have cups-bsd.  
I have killed xprint and removed it from /etc/rc2.d/.  Everything 
foomatic is installed.  No errors showing in the error log (at a normal 
logging level).  I tried upgrading to the latest cups etc to no avail. 
There must be a simple rational and reliable way of getting it to work
in a predictable timescale, surely?


Reply to: