[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accessing a USB mass storage device


I have a Philips USB mp3 player that I'm trying to access under Debian

In a nutshell, I can plug the device in and linux will see it, but I
can't actually work out how to copy files to and from it.

Can someone tell me how I can do this?

I've tried running "mount /dev/sda /mnt", but it wants to know the file
system type. I have no idea what file system type it is, or even if this
is the right thing to do.

I've also tried just doing "cat /dev/sda" but all I get is screens and
screens of garbage. The first line of garbage it outputs includes the
text FAT16, so I've also tried "mount /dev/sda -t vfat -o fat=16 /mnt",
but that returns the following error:

mount: wrong fs type, bad option, bad superblock on /dev/sda,
       missing codepage or other error

I've included below output from lsusb, dmesg and /proc/bus/usb/devices
that I hope is relevant. udev and hotplug are installed.




Bus 002 Device 008: ID 0471:0142 Philips


usb 2-1: USB disconnect, address 3
usb 2-1.1: USB disconnect, address 4
ohci_hcd 0000:00:02.1: wakeup
usb 2-1: new full speed USB device using address 5
hub 2-1:1.0: USB hub found
hub 2-1:1.0: 5 ports detected
usb 2-1.1: new full speed USB device using address 6
hiddev96: USB HID v1.00 Device [0698:1786] on usb-0000:00:02.1-1.1
usb 2-1.2: new full speed USB device using address 7
SCSI subsystem initialized
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
  Vendor: PHILIPS   Model: Key Ring (128MB)  Rev: 0001
  Type:   Direct-Access                      ANSI SCSI revision: 02
USB Mass Storage device found at 7
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
SCSI device sda: 256001 512-byte hdwr sectors (131 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
 /dev/scsi/host0/bus0/target0/lun0: p1
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0


T:  Bus=02 Lev=02 Prnt=05 Port=01 Cnt=02 Dev#=  7 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0471 ProdID=0142 Rev= 0.01
S:  Manufacturer=Philips
S:  Product=Wearable Audio Player (128 MB)
S:  SerialNumber=012345678901
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50
Driver=usb-storage E:  Ad=04(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms

Reply to: