[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot connect to network now...

Brian Coiley wrote:

Here is the story so far:

1.    Installed Woody dual-boot on my W2K box
2.    Couldn't get Nvidia card to work
3.    On the advice of this NG, upgraded to Sarge
4.    Tried to install a 2.4 kernel.  Need to change LILO config, but I'm
not using LILO, I'm using NTLDR...
5.    Figured out how to change from using NTLDR to LILO, and tried again to
install the 2.4 kernel.
6.    2.4 kernel would not boot (interrupt failures on hard drive)

7.    So, installed a 2.6 kernel.
8.    Still can't get Nvidia card to work with nv driver.
9.    After much fiddling around with configuration, managed to get startx
to do something using VESA, but just shows a grey screen with a black cross
in the middle, and entire system is locked up.
That means your X server is running, but it's not running any clients (like an xterm, or more commonly, a window manager (like icewm or wmaker) and/or window environment (like KDE or Gnome).

Try "apt-get install icewm" and then restart your X server. That should be a bit more comfortable. For more bells and whistles, try "apt-get install kde".

10.  Hit the big power button and booted again.

Almost certainly not necessary. Just hit Ctrl-Alt-Backspace to kill X. Or press Ctrl-Alt-F1 to switch to the first Virtual Terminal (VT1); Ctrl-Alt-F2 will switch to VT2, etc. Ctrl-Alt-F7 will (most likely) switch back to X, although since you don't have any X clients running, that's fairly useless in your case.


Linux is now completely unable to see my network.

My gut instinct is that you're not loading the correct module for your NIC. In the 2.2 kernel, it was probably built-in. in the 2.6 kernel, I believe it's a module. You can run "modconf" to select the correct module for your NIC (there are other ways as well, but this is probably the easiest).

You also might need to install "discover" (I believe that's the package name), which will do some automatic hardware discovery and load up the necessary modules. I believe this is the way of the future, rather than manually loading modules via modconf, etc.

 Fails to get an IP
address from the DHCP server, doesn't work, nix, nothing!  This is NOT a
hardware problem: it works fine if I boot to Windoze.  And it was working
fine for 2 days, up to an hour ago.

I have not got the foggiest idea how to begin diagnosing this latest
problem.  Something has clearly gone wrong with the NIC/driver setup in
Sarge, but I don't know where to begin.

Please help!  Windoze is beginning to look like considerably better value
than the £3 I paid for the Debian CD's, which will shortly become a set of
nice shiny coasters!

I understand your frustration. However, once you've gotten over the hump of the learning curve, you're going to know a lot more than do your peers about Tomorrow's operating system.

And I gotta admit; Microsoft makes it easy on the end-user, at least at first. Until the viruses hit, and the license fees, and the inflexibility, and the gradual creep of slowdown that occurs over several months, and the single-user mentality when a multi-user mentality is called for, and the lack of being able to _control_ your own box, etc. There's a trade-off, but as a former Microsoft fanboy, I can say that it's well worth it.


Reply to: