[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: windows locks up while accessing samba shares

> On Thu, 30 Sep 2004 20:06:20 +0100, Ognjen <ognjen <at> mailshack.com> wrote:
> >  I have a server running debian (testing) with samba. All permissions etc...
> > work and i can create folders etc.... my problem is that when i try to
> > transfer files on the server windows (win2000 prof) locks up. after
> > rebooting and going back to the server i find that the file has been
> > transferred with no problems
> > 
> > Also if i try to open any file on the server (it opens folders just fine)
> > windows locks up as well. basically any (read) file access locks up windows
> > but write does not, i would have put it down to faulty windows installation
> > had i not found out that other people who also accessed the server got the
> > same problem (windows lockup (win 2k & XP tested) ).
> > 
> > I believe it must be related to the server (possibly samba). while this is
> > my first attempt at using debian in a server i have used redhat before yet I
> > have never had a problem like this before, what could be causing it? (note
> > that from the server directly i can access the files with no problem)

I have few clues but encounterned the problem today (win2k and Xp tested).
I upgraded from 3.0.5 to 3.0.7 with a bunch of packages -> the samba server 
was down for few minutes.

I don t know if it s the server upgrade or the timeout though explorer.exe
crashed  on some folder (not all) of the samba server. Seems those were the  
ones which where accessed before the upgrade.

I suggest stopping the samba process completely (checking there s no nmbd or
smbd processes left. Then restart it. Retry to access the broken directories/
files from windows. If it still fails you should try killing every explorer.exe
process in the windows box (with the process manager) and restarting it from 
there (look in the process manager menu for the execute command).

If it still fails wait a 15 min and retry (i guess that s the time it take 
on my net for the windows network "election process" to complete). 

Please forward what helped, as i tried them all and don t know which one 
fixed it.


Reply to: