[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt problem - ldconfig segmentation fault

A re-install seems to have fixed it. Although I have no idea how it broke in the first place.


Joris Huizer wrote:
Graham Smith wrote:

I tried installing nmap a couple of days ago and ran into a bit of a problem. ldconfig seems to have died with a segmentation fault. In the past when I have had problems with apt they have resolved themselves in a couple of days when a working version of a package appears but this problem isn't fixing it self. I have had a good google for it but I can't find anything particularly relevant. Any help would be greatly appreciated.

I am running testing with the 2.6.7 kernel on i386 (slightly off topic question but I am sure I saw 2.6.8 appear and then disappear from testing and I can't find kernel-image-2.6-386 in testing any more has it been removed for some reason?)


What happens if you do,
  apt-get --reinstall install libc6
(ldconfig is provided by libc6)

If that doesn't work, I'd try the libc6 source (apt-get build-dep libc6 && apt-get -b source libc6)



Reply to: