[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DMA issue

On Wednesday 22 September 2004 14:50, Josh Lauricha wrote:
> I have the following:
>  Athlon XP 2800+
>  Western Digital 180GB (WD1800BB)
>  Generic 16x DVD-ROM
> And am getting:
>   hda: dma_timer_expiry: dma status == 0x21
>   hda: DMA interrupt recovery
>   hda: DMA timeout error
>   hda: DMA timeout error: status=0xd0 { Busy }
>   hda: DMA disabled
>   ide0: reset: success
>   hda: lost interrupt
>   hda: task_out_intr: status=0x59 { DriveReady SeekComplete DataRequest
> Error }
>   hda: task_out_intr: error=0x00 { }
> hda: DMA disabled
> hda: drive not ready for command
> ide0 reset: success
> Regularly. The drive will reset (with an audible click), then do a
> little more and timeout again. I'm trying to install Sarge running
> 2.6.8, but the same problem happens with 2.4.26. I've tried booting
> with noacpi, nodma, ide=nodma and noapic with no success. I've tried
> different combos of connecting the drives, both on primary, dvd on
> secondary, etc. I've disabled DMA in the BIOS, but it still seems to
> try to use it. I've reset the BIOS. Is there anything else I can try?
> Anyone else running one of these boards? Based on the dmesg output, it
> doesn't seem like the noapic arg does anything on this board.
> Please CC, I'm not subscribed.
Are you sure the drive is good?  I had problems like this, and smartmontools 
showed the drive was failing.  I replaced it, and haven't had any problems 

Justin Guerin

Reply to: