[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: VIA sound problem

I had problems too. The kernel kept loading the oss modules, which meant that 
the alsa ones didn't work. I took advice from somewhere on the net, which 
said the way to stop it was to edit /etc/discover.conf and put a line

skip via82xxx_audio

which means it will never use that module. Then alsaconf was able to insert 
the correct ALSA modules and all worked ok....

The other weird thing to watch out for is that PCM volume control doesn't 
exist - it's on or off. And on mine, the only volume control which does 
anything is one called VXD1 or DXsomething1 anyway, it's the first one with 
an X in the name (sorry, it's on my home machine!).


On Wednesday 01 January 2003 00:05, jochen wrote:
> I have the following problem:
> I'm running kernel 2.6.8.
> After installing, configuring and compiling the kernel everything works
> fine except sound.
> I got a vie-onboard card and it worked perfectly in
> Here's the lspci output:
> 0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc.
> VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
> Alsa recognizes the soundcard, after doing a "modprobe via82cxxx_audio"
> I can play sound as root.
> The problem is that I can only use mplayer to play sound, and mplayer
> hangs after playing the file for several seconds (it also hangs when
> quitting the application while playing)
> If I use xine then it plays the video part put the sound hangs.
> What's wrong? I don't get it.
> Is there a known problem with that driver?
> CU
> Jochen

Reply to: