[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

sound problem flashplugin-nonfree



Since moving to the 2.6 kernel I get no sound from Flash. I had sound in
2.4, but not in any of the 2.6 kernels that I've used.

Shortly after switching to 2.6 I began using my on-board sound, as it
required alsa, but still no luck. The sound works fine with other
applications. I really don't think it's hardware related, as I lost
flash sound on a completely different machine when switching to the 2.6
kernel.

I ran without esound for a long time, just using the alsa output in
other applications, but adding and running the esound server made no
difference in flash.

I normally use mozilla-firefox, but I have also tried mozilla-browser
and mozilla-firebird with no luck. I tried "dpkg-reconfigure
mozilla-browser", using every dsp wrapper option. Using "esddsp", the
browser freezes while playing a flash file. Using any other wrapper
setting, it just plays with no sound.

I tried "esdctl unlock", but no luck. I tried "killall esd" before
loading a flash animation, but nothing.

I'm running Debian "testing", custom kernel 2.6.6, firefox 0.8,
flashplugin-nonfree 7.0.25-4, esound 0.2.29, alsa 1.0.4rc2 with a via
8235 sound card.

Any ideas?



Reply to: