[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Dial on demand not working when ipmasq installed

Hello all,

I am trying to set up dial on demand for dsl on a box that is meant to run as router for a masqueraded home-network. I am using debian/sid wich is up to date.

I set up the dsl connection with pppoeconf, which worked fine. In /etc/ppp/peers/dsl-provider I uncommented "demand" and "idle 300" and commented out the "usepeerdns"-part as I entered my ISP's dns servers manually in /etc/reslov.conf

When I now start up ppp by "/etc/init.d/ppp start" the interface ppp is brought up and - as expected - the dsl-connection is not established yet. When I try a ping to my ISP "ping www.t-online.de" the connection is established, the pings comes through and answers. Now problem.

Now I installed ipmasq to make the connection available to the computers in the LAN. After restarting ppp and trying the same ping command I got "unknown host: www.t-online.de" as error message. Allthough both dns-servers of my ISP are still present in /etc/resolv.conf

I did a dpkg-reconfigure ipmasq and set it up to be started _after_ all network services have been started. Before it was set up to start after network interfaces were up.

Again I did a restart on ppp and ipmasq and tried the ping command. Directly after restarting both ppp and ipmasq the ping causes the dsl-connection to be established and masquerading seems to work. But: I wanted to see if dial on demand still works after the idle time expired and the connection was hung up, so I again tried "/etc/init.d/ppp restart" and then the ping command again. Result: NO CONNECTION is being established, instead I get the error message: "ping: operation not permitted."

I googled around and found that this seems to be caused by a missconfigured firewall. But I have not changed anything in the ipmasq settings. The only hint I got on IRC was to set up masquerading manually with iptables and get rid of the ipmasq-package. But that does not seem to be the ultimate solution ;-(

Can anyone help me please? I need to get this working with dial on demand. What is the problem with ipmasq that dial on demand does not work reliably any more?

Help would be appreciated.


To reply to this posting directly use the following address and
remove the 'NO-SPAM' part: Riedel.Christian.NO-SPAM@gmx.net

Reply to: