[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get dist-upgrade and /dev/input/mice

On Fri, 2004-07-16 at 17:27, Brian Walker wrote:
> Using Sarge and regularly apt-get updating and upgrading I ignored the
> uninstalled gnome and kde, using blackbox wm, mutt and slrn. Thought I
> would try to fix the box before migrating to unstable.
> apt-get upgrade followed by apt-get dist-upgrade. Box is now borked.
> No mouse at log-in time, ^/Alt/F1 to command line. All seems well on
> dmesg, but XF86config error messages show that /dev/input/mice does
> not exist ... ls -l shows it present (and mouse0,1 and 2) but unable
> to be opened by most/less or xemacs.
> dpkg --configure --pending shows unmet dependencies. Reading man dpkg
> and man dpkg-reconfigure .... no luck with the choices there.
> aptitude, dselect both complain of the dependencies and stop there,
> just like dpkg (sorry, unable to paste the output, and am on the XP
> part of my system now)
> dpkg --configure --pending shows a slew of unmet dependencies: current
> versions are newer than the required dependencies, as you would
> expect.
> 1. How can I continue with the upgrade, ignoring these dependencies?
> Large numbers of updates remain unconfigured, and I cannot get the
> system to ignore the problems and pass onto the rest.
> 2. There is a dangerously unstable package - imhangul -
> half-installed. I am unable to install (as suggested by dpkg) nor can
> I remove. Which command can be tried? I have tried dpkg variants of
> -i, --ignore-depends, --reconfigure, --configure --pending, and
> apt-get remove
> 3. Should I forget the Srage version, and simply reconfigure the
> apt,sources for unstable, and dist-upgrade using aptitude from that?
> Brian

Hi Brian,

	I had this a couple of times (I'm using Sarge for about half
a year) while updating/upgrading reguarly. In my experience there is
usually 1 package which causes this. By doing a apt-get -f install \
package, (-f == force) you can usually force your way through this,
although the last time I did this, I had to force a sid package in.




Reply to: