[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

re: XF86Config problem serverflags section or xset

Pigeon wrote:

On Wed, Jun 23, 2004 at 01:58:42PM +0200, Paal Marker wrote:
I need to prevent a box from blanking out.

In redhat8 I could succesfully put this section in the end of /etc/X11/XF86Config

Section "Serverflags"
    Option      "BlankTime"    "0"       Option      "StandbyTime"  "0"
    Option      "SuspendTime"  "0"
    Option      "OffTime"      "0"

The result of putting in this section is that the X server will not start

By googling I found that this syntax could also be used

Section "Serverflags"
Option "blank time" "0" Option "standby time" "0"
    Option      "suspend time"  "0"
    Option      "off time"      "0"

Same result, no X

startx gives error message:
Option "blank time" "0" server flags section keyword expected

I copied the serverflags section from redhat8's XF86Config, where it worked fine. What does debian demand of syntax here?

I've got "xset s off" in /etc/X11/xinit/xinitrc. Works fine.

Yes, you are right, and I have tried it. Correct on this system will be 'xset s off -display ":0"' But the problem is that anyway where I put that command to execute , be in /etc/X11/xinit/xinitrc or /home/kiosk/.xsession or wherever it does not work. However, if I log in remote by ssh and execute xset s off -display ":0" from bash prompt, it works fine.

According to man xset, the xset command must be executed after all applications, so I have tried to execute it from the last line of /home/user/.xsession.

I had the same problem making kiosks with redhat as well, and ended up by solving it with the serverflags section in XF86Config.

Continuing exploring the section "serverflags" problem:
From linux single start and the startx  I get the error message:

Config Error: /etc/X11/XF86Config:269 (wich is the line where the first option in the section serverflags starts)

_Option__ "BlankTime"   "0" Server flags keyword expected

Remark here that it is the Option word that is underlined in the message, the underlning is made by ^^^^^^^ these characters. Does it tell me that 'Option' is an invalid keyword in this section?

The Xserver used is xserver-s3

I will be happy for advice for any solution here, being by XF86Config and serverflags, or how to execute xset s off

Reply to: