[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Network access gone after recompile

Aaron Robertson-Hodder wrote:

I’m pretty new at this Linux stuff so go easy on me!

I installed the latest Debian distro using the network install, so obviously my internet access was working fine. Then I compiled the 2.6.6 Kernel and installed that and now I have no internet access.

I searched the kernel config for a driver for my card (a Realtek 3189) which I know is supported, but could not find it. I have checked /etc/network/interfaces and it seems right to me, but when I run etherconf, it says there is no card detected. Now, it seems I can compile a driver for this card (I think the module is 8139too) but if it worked before the new Kernel install, why would it not work now, and does anyone know how I can fix it easily?



modprobe 8139too

and then

ifup eth0

and see if that works. If it does, then put "8139too" in a line by itself in /etc/modules.


Ken Simon
Homepage: http://ninkendo.org

Reply to: