[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

mono + wine + windows.forms

I'm trying to run programs written in C# (mono) with Windows.Forms under
Linux. Unfortunately without success. I've got complete mono and
mono-wine from:

deb http://www.debianplanet.org/mono testing main

I run win32server as root and then:

$ wine form.exe

and w i've got message ,,You have to install M$ .NET Framework....'' and
program finish (exactly the same text I could get running .NET soft on
mswindows without framework). Log:

When you are running with a native NT directory specify
'Profile=<profiledirectory>' or disable loading of Windows
registry (LoadWindowsRegistryFiles=N)
fixme:shell:UrlIsW (L"Y:\\dev\\cs\\forms\\form.exe.config" 0): stub
Wine exited with a successful status

but when I start like that:
$ mono form.exe

I've got messages:

MonoWin32: Initializing WineLib
fixme:cdrom:CDROM_GetIdeInterface not implemented for true scsi drives
Could not stat /home/snieradka/.wine/%HOME% (Nie ma takiego pliku ani katalogu), ignoring drive Y:
When you are running with a native NT directory specify
'Profile=<profiledirectory>' or disable loading of Windows
registry (LoadWindowsRegistryFiles=N)
Warning: Language 'pl_PL' was not found, retrying without country name...
Warning: Language 'pl' was not recognized, defaulting to English
fixme:keyboard:X11DRV_KEYBOARD_DetectLayout Your keyboard layout was not found!
Using closest match instead (United States keyboard layout) for scancode mapping.
Please define your layout in windows/x11drv/keyboard.c and submit them
to us for inclusion into future Wine releases.
See the Wine User Guide, chapter "Keyboard" for more information.
err:menu:MENU_GetSysMenu failed to load system menu!

Unhandled Exception: System.EntryPointNotFoundException: GdipCreateFontFamilyFromName

That's my
- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (600, 'testing'), (50, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.3
Locale: LANG=pl_PL, LC_CTYPE=pl_PL

mono -V
Mono JIT compiler version 0.30.2, (C) 2002-2004 Novell, Inc. www.go-mono.com

What am I doing wrong?

PS. Please write on my address. I'm not a member of debian-user group.

/// Szymon Nieradka

Reply to: