[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: iptables

Adam Aube wrote:
Tom Allison wrote:

I was trying to write up an iptables script last night and managed to
get it work, or so I thought.

When I run it, the interface just dies.
It's still configured and "up", but any kind of traffic sent to it is
ignored.  I even added lines like:
iptables -A INPUT -i $IFACE -j LOG
and I don't get any logging in /var/log/syslog

Try using the dmesg command.

What's worse, if I remove all the rules and reset the default policy to
ACCEPT it doesn't get any better.


Cute problem solved.

I had set the table, "mangle" to DROP and didn't realize that everything goes through this table. Since I'm not using NAT I was ignoring that table.

I was taking notes from a book and realized that the guy who wrote it made one mistake. But put all the tables to a default Policy of DROP which isn't really the way to go. IIRC only the table, "filter" should have the default of DROP. Probably to avoid stupid questions on the internet... :)

Thanks to all who responded.

Now I just have to figure out how to get FTP straightened out.

Reply to: