[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: suffering from an apparently broken tcp

Kim Sparrow wrote:
So I managed to set up a Debian Woody box with Tomcat + Scarab,
Apache + Subversion, winbind authentication, Mailman, and a few other
goodies. I thought that everything was fine, until I tried to move the
existing Subversion repository over to the new system via SMB. I then
found that files larger than 64k would transfer at pitiful rates --
essentially, chunks (64k or smaller) of the files would float over with
gaps of many seconds between them. At first I thought the problem was
essentially a Samba problem, but I achieved similar (lack of) results
with FTP and HTTP. This behavior is limited to the local network; file
transfer from the Internet moves at a good clip. Additionally, pulling a
file from the Linux box to another computer on the network works just

Now I'm at a loss for what's going on, and Linux system administration
isn't at all my specialty. I've looked all over the Internet, and only
found one message thread noting similar behavior: gaps in transmission
from the Linux box to Win2k, but good receive behavior. The resolution:
it went away by itself! Anybody have a clue? The thing is essentially
unusable as it is!

Relevant (?) specs:
Dell Precision 420 - Dual 800MHz P3, 512MB RAM
Integrated 3com 3c920 (3c905C compatible, according to the Dell site)
Kernel: (I started out with 2.4.19; switching was an act of

Any help would be greatly appreciated!

Kim Sparrow
Sr. Software Engineer
Speed of fiber.  Flexibility of wireless.

I suffered from a similar problem on a woody box. After a lot of frustration and testing, I found out that a lot of UDP packets were getting dropped in local network communications during high volume connections. I still don't know exactly what was going on, but I believe that it was at least partly faulty drivers for my nic. Upgrading my kernel to 2.4.x solved my problems. You're already ahead of me there, having upgraded your kernel a few times. I can only suggest grabbing a good high-volume network performance analyzer to see what's going on. I *think* the tool I used was called netperf.

Good luck!


Reply to: