[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: broken cups in sid

On Tue, 2004-06-01 at 22:47, richard lyons wrote:
> On Tuesday 01 June 2004 14:39, Tristan Mills wrote:
> > On Tue, 2004-06-01 at 19:10, richard lyons wrote:
> [...]>
> > cupsys shouldn't be depending on libcupsys2. Its kdelibs4 (and
> > probably 3) which do. If you can live without KDE then getting rid
> > of it should sort this out, otherwise wait for updates or compile
> > kdelibs yourself.
> Are you suggesting I remove all of kde, get the source for whatever is 
> packaged in kdelibs4, compile it (making sure somehow not to depend 
> on libcupsys2) then reinstall kde (somehow making sure it doesn't 
> replace my kdelibs?  Is that do-able by someone who has never 
> successfully compiled anything?  It's a handful of work for the three 
> or four apps I use from kde.

Its probably not the easiest thing unfortunately... (I do forget that
others havn't had the same experience with computers as I have sorry
about that).

> > If you have an old cupsys installed then that will be depending on
> > libcupsys, so uninstalling that before installing the new version
> > should sort that out. Otherwise I have no idea what's going on...
> That seemed like a good idea.  I removed cupsys and friends (via 
> aptitude).  Then tried to install them.  Nothing happened.  Aptitude 
> claimed 0 packages to be installed.  I tried apt-get install cupsys.  
> Apt-get wanted libcupsimage2, libcupsys2-gnutls10, and gs-esp in 
> order to install cupsys.  Then it listed 229 packages to remove - 
> comprising all of kde, so I stopped.  This is similar to what I saw 
> in aptitude: a cascade of dependencies on libcupsys2 which starts 
> with kdelibs4.  AFAICS that implies that kde is currently 
> incompatible with cups printing in sid.

Yup. That's the case...
KDE (specifically kdelibs) depend on a version of libcupsys compiled
against an old version of libgnutls. Unfortunately the new and old
versions won't coexist (or at least their packages won't) so with the
packages as they are you can't have both...
It sucks.

Just looked at the debian-qt-kde list and the solution suggested is to
install the testing version of libcupsys (and presumably the testing
versions of anything for which the unstable versions won't then work).
If you're not using Gnome this should be fine.
(I actually had to do a similar thing to get evolution working, although
the old lib would happily install alongside the new one in that case)

Hope you can get it working,

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: