[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: broken cups in sid

On Tuesday 01 June 2004 14:39, Tristan Mills wrote:
> On Tue, 2004-06-01 at 19:10, richard lyons wrote:
> cupsys shouldn't be depending on libcupsys2. Its kdelibs4 (and
> probably 3) which do. If you can live without KDE then getting rid
> of it should sort this out, otherwise wait for updates or compile
> kdelibs yourself.

Are you suggesting I remove all of kde, get the source for whatever is 
packaged in kdelibs4, compile it (making sure somehow not to depend 
on libcupsys2) then reinstall kde (somehow making sure it doesn't 
replace my kdelibs?  Is that do-able by someone who has never 
successfully compiled anything?  It's a handful of work for the three 
or four apps I use from kde.

> If you have an old cupsys installed then that will be depending on
> libcupsys, so uninstalling that before installing the new version
> should sort that out. Otherwise I have no idea what's going on...

That seemed like a good idea.  I removed cupsys and friends (via 
aptitude).  Then tried to install them.  Nothing happened.  Aptitude 
claimed 0 packages to be installed.  I tried apt-get install cupsys.  
Apt-get wanted libcupsimage2, libcupsys2-gnutls10, and gs-esp in 
order to install cupsys.  Then it listed 229 packages to remove - 
comprising all of kde, so I stopped.  This is similar to what I saw 
in aptitude: a cascade of dependencies on libcupsys2 which starts 
with kdelibs4.  AFAICS that implies that kde is currently 
incompatible with cups printing in sid.

Thanks, nonetheless.

Reply to: