[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Question about installing nvidia driver

On Sun, 23 May 2004 20:13:54 +0200, LeVA wrote:

> 2004. május 23. 18:19 dátummal Alexander Schmehl ezt írta:
>> * LeVA <leva@az.isten.hu> [040523 16:25]:
>> > You must have the compiled(!) kernel sources, if you are using 2.6.*.
>> Shouldn't kernel-headers be sufficient?
> When I've compiled my 2.6.5 kernel, and installed the nvidia drivers, it
> was ok. But after the make clean in /usr/src/linux (symlink to
> linux-2.6.5) the installer didn't work. And that was because it couldn't
> find the version file, which contains the kernel source's version, which
> exists in the 2.4* kernel's sources by default, but with 2.6* kernel, you
> must make the kernel to create that version file.
> This is just my experience. Try it, and you'll find out if it is working.
> Daniel
just built nvidia drivers (nvidia installer), all I have is stock Debian
kernel and kernel headers; worked like a charm for me, perhaps it's just
beginner's luck (potential Mandrake convert ;-) ).

$ ls -l /usr/src/linux
/usr/src/linux -> /usr/src/kernel-headers-2.6.3-1-386

which is mostly symlinked to ../kernel-headers-2.6.3-1 (hope I'm
doing this right...)

$ uname -r

Reply to: