[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unable to install "woody" on i386

As root, run dselect
Choose option 2, 'select: request which packages you want on your system'
Next you will see a screen reading: Help: Introduction to package list.
Read through the screen's instructions, then hit the space bar when
finished which will exit you from the screen.
Next you will see 'dselect main package listing'.  This lists all the
available packages both installed and yet to be installed on your
system. When you originally installed your system (assuming you
installed from cds), the installer read the index files of all the
available packages on each cd, but didn't install all of them.  Now you
can see all these packages...the ones you first see have an * marking
them as already installed.  Use your cursor keys or page up/down keys to
scroll up and down this list.  The screen is split in two, the upper
half lets you highlight a particular package, the lower half offers a
detailed description of that highlighted package.  As you scroll down
you will notice related packages group together under a descriptive
heading, for example, "Important packages in section utilities" and so
on...  'Available Optional packages in section x11' is where
you'll find the package, 'xserver-svga' and you'll want to highlight it
and then press the + key which will place a '*' character at the
selection telling you that it's marked for installation.  When you hit
the + key, another screen "Dependency/conflict resolution -
Introduction" will appear...read through it to educate yourself, then
hit the spacebar to exit that screen.  Now you'll see a list of packages
that also need to be installed to make the selected package run
properly.  They will already be marked with *, so all you really need to
do is hit the enter key to exit that screen.  But you'll notice that
there will also be "suggested" packages associated with the selected
package which you may or may not want.  I'm speaking in a general
fashion regarding the installation of Debian packages.  I can't remember
exactly, but most likely the only packages displayed related to
xserver-svga will be required packages only.  If that's the case, simply
hit the enter button to exit, since the required packages will already
be marked for installation.  The screen just serves to inform you of
that fact.  When you hit enter you'll be back at the 'main package
listing'.  Hit enter again and you'll exit that and be back at the main
dselect screen with option 3 'install' already highlighted.  Hit enter
again and this will start the installation process.  The screen will go
blank and some messages will appear such as: "reading package
lists...done  building dependency tree...done" and so on...  It will
give you a summary of what is to be install (and/or removed), how much
space will be used/freed and will prompt you for a y/n to continue.
Press y for yes and hit enter.  It will then say "media change.  please
insert disk labeled, 'particular disk number' (it may ask you to
insert yet another disk during the installation process...in any
case...go ahead and pop that cd
into your drive and hit enter...it will then go into a preconfigure mode
that will ask you the questions relating to which server you want to use
(most likely you already have xserver-xfree86 on your system, which you
DON'T want), so go ahead and choose 'xserver-svga' and then it will ask
some other questions...answer them as accurately as you can, especially
the video resolution selections...you can choose multiple settings which
will naturally default to the highest supporting setting, but I suggest
you don't go above 1024x768.  Also make sure your mouse is mapped
accurately...probably belongs at ttys0.  After the preconfiguration,
dselect should start unpacking and setting up your selected package(s).
After it's done you will be prompted whether or not to erase
previously downloaded deb files...say yes to this since you don't
need them after they're unpacked and set up...it will then tell
you to press enter which should bring you back to the main dselect
screen.  Choose option 6 'quit dselect' which will bring you back to the
root prompt.  Type in 'startx' and you should (hopefully) be in
Good luck.

pieter <nouwens-kristensen@zonnet.nl> wrote:
Dear Aldous,

I know about the head-banging part allready. But the rest I still have some questions about.

When I say "dselect" being "root" there appears only a short list of six items:

0   acces
1   update 
2   select
3   install
4   config
5   remove
6   quit

In my case number six would be the end of the list. There is no more. I'm sure I am on the right track now, but not quite there. Could you please point me in the right direction again?

thanks, Pieter

Aldous Huxley schreef:
I don't babysit the Debian User List religiously, so I'm not sure if your problem was even addressed or solved (going through old messages now).
When I first installed Debian Woody on my i486 133mhz, 64meg RAM, 1.2gig system with a Trident SVGA videocard, I had the same type of problem that you have.  Every time I tried to startx the system, I would get error messages after the screen would flash on and off several times.  I did 'dpkg-reconfigure xserver-xfree86' many times using every available driver listed...just to be sure...and nothing worked.
Debian Woody installs the xfree86 server by default which doesn't work on many older systems like ours.
You need to:
log on as root
type 'dselect' and hit enter
scroll down to video server selection (I only have the first two disks of Woody and the video server selection was down near the very end).
choose 'xserver-svga'
during preconfiguring stage prior to installation you will be asked some basic set up questions, answer them appropriately, especially the amount of screen resolution, and your mouse is probably best configured to ttys0.
I'm a linux newbie, so take my advice with a grain of salt...but this solution worked out for me after many, many hours of trial and error (and head-banging).
Good luck!

slmpe <nouwens-kristensen@zonnet.nl> wrote:
I seem to be unable to install Debian 3.0 on my computer. That is to say: everyting goes without any problems. After the end of the installation-process I am asked to log in. I do this and again sucessfull. Then I type "startx" and I get the message:
"x connection to: 0.0 broken (explicit kill or server shutdown)"
Furthermore I read
"no screen"
I hope some of you can give an easy solution. I gave up. I tried a lot.
Pieter Kristensen Netherlands

Do you Yahoo!?
SBC Yahoo! - Internet access at a great low price.

Do you Yahoo!?
SBC Yahoo! - Internet access at a great low price.
Reply to: