[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6 LVM problem

Stephan Seitz wrote:
But you need lvm2 for kernel 2.6.*. And I don't know if there is an
upgrade path to use the old lvm1 with lvm2. It should be
backwards-compatible, but it uses different config files.

The lvm2 package doesn't contain any docs for an upgrade (or I didn't
find them).

Actually it works automagically, just install lvm2 and you are fine. I did it just this past weekend -- installed debian sarge from scratch using beta4 installer, with kernel 2.4, configured lvm, installed lvm2 package, compiled kernel 2.6.5, rebooted.. and lvm came up just fine. If lvm2 package is missing than you will get lvm working under 2.4 but not under 2.6. I remember reading somewhere that lvm10 and lvm2 packages are smart, they basically install proxy lvm tools which determine your kernel version and run appropriate userspace lvm tools (10 for 2.4 and 2 for 2.6). I don't remember where I've seen this information though...



Reply to: