[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Strange server crash on woody with gallery/php


i'm maintaining a web-server through the web on a plain debian woody box. I wanted to use the gallery program, to create a photo gallery. Because I like it's features and I'm using it on other a unstable debian box, I wanted the 1.4.3 version, so I downloaded the package for testing by ftp and installed it on the box via dpkg -i. (I don't know if it is the best way to do so, but it worked, apt-pinning should be better, but I didn't get it by now... )

The gallery seems to work, I can login, upload images on after the other, add comments and everything. The problem comes when I try to upload a bunch of images. To do so, I uploaded all my images to the server, and then gave the path to the directory to the program. Gallery begins by copying the images to a temp directory, and then does some rescaling via convert and netpnm. And there comes the problem: at some point on the process, the server turns off. It doesn't shut down, it turns off. Nothing in the logs:
syslog has some " -- MARK -- " and then "syslog restart"

it doesn't seem to be the rescaling program, the bug comes some times before rescaling, some times after. Gallery has some debugging messages, so I tried some of the shell comands run to rescale, and had no problems doing so. Only thing I know is that the process is a little processor and disk intensive.

I have only access to the machine by ssh and web interface, so it's not really easy to test and restart the machine after a crash :-D To day, I tried the procedure while phoning somebody on site: The server seems to shut off in half a second, without error messages. We did it while looking on the console with ctrl-alt-F1 to see if the kernel prints something to the console, but nothing appears, the screens only turns black.

I don't know what this could be, the machine is new, and it's kinda scary to put a machine with this kind of bug on the net.

Any clues, things to try ? I tried with the gallery forums, but I can't write there, I'm not getting my register confirmation with my password. I'm now looking into apt-pinning to try this one out whith another version of php, I read that php 4.1.2 had some bugs.



Reply to: