[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Newby can't get Xwindows running

On Sun, May 02, 2004 at 03:51:13PM +1000, David Moore wrote:
> As a complete novice to Linux, please bear with me if my explanation of the
> problem is confused.
> I installed Debian 3.0 r2 woody kernel 2.2.20 (many times on 2 different
> machines) using defaults and keeping as simple as possible, but I have not
> been able to get XWindows running.

If its a workstation and not a server I would get the new installer
beta (sarge) and install either testing or unstable. The version of X
there and the kernel version is much newer and could solve some
problems, also IIRC the installer has some hardware recognition (don't
know if for X though).

I looked at the X version in stable and it looks like its 3.3.6 (which
is very-very old). If you want to use stable go to
http://www.backports.org/ and see how to add the backport packages
(there is a HOWTO and installation instructions) and
upgrade X (its 4.2.1 there although unstable and testing already
have 4.3).

unstable is more stable then it sounds (I rarely have problems and then
it will just inhibit me from installing problematic packages unless I
bypass things), testing is ok now since its entering a freezing state
on its way to become stable, although usually unstable is more stable
and secure then testing. For a desktop unstable is usually the best
solution (unless you want to run stable with back-ports).

You could also try the knoppix (http://www.knopper.net/knoppix/),
meppis (http://www.mepis.org/) which have good hardware recognition,
can install to the hardisk or run of a cd and are based on mix of
debian testing/unstable.

> I used taskel to select: XWindows, Desktop environment and C/C++ 
> It boots into the bash shell fine except that during boot-up a message
> appears: "Modprobe can't locate char-major-10-135"  (the pause key doesn't
> halt the screen during boot-up so other important message might flash past
> before I can write them down)
> I have a Matrox MGA G200 - 16Mb
> Phillips SL200 19" monitor
> MS 2 button mouse on PS2 port
> The problem is, when I try to run X, XFree386, xdm, kdm or gdm it does not
> go to VGA mode but spews forth dialogue including the following lines which
> seem significant:

could you post the output of running startx (try also as root to make
sure that there is no permission problems) and the file
/var/log/XFree86.0.log which may help to see the error messages.

> "	Warning couldn't open module mga_hal
> "	MGA: Failed to load module mga_hal (Module does not exist, 0)

Try using the generic vga driver as a start and see if that solves the
problem first. If that works it will be easier to activate the mga
driver next. Also try doing modprobe agpgart (assuming you have agp, don't
remember if accelerated pci also uses agpgart or pcigart, try both).

> "	EE Screen(s) found, but none have a usable configuration.

Try reducing the resolution and refresh rate as a start to 1024x768 and
75HZ as a maximum, maybe its having problems with recognizing your
monitor. Again if this works its easier to improve afterwords. IIRC
there is an simple and novice options for setting up the monitor
refresh rates which should let you choose something close as a start.

> "	Fatal Server error no screens found
> if I run xf86cfg, it goes to VGA mode and brings up the XWindows
> configuration modules, but the mouse doesn't work.

Could be that you mouse isn't configured properly. X will crash in such
a case and give errors that seem to indicate screen problems instead of
mouse problems. I ran into this several times and it was usually the
last place where people look.

What mouse do you have (brand and ps/2 or usb?). Post the generated

> I run xf86config and re-enter the hardware specs (to the best of my
> ability), but this makes no difference.
> I am basic level user with unix (some years ago), and without gui feel like
> I have been thrown in the deep-end in a tied sack. If I had XWindows I could
> probably start swimming.
> David
> --------------------------------------
> David Moore
> dmoore@geomap.com.au
>  +++++++++++++++++++++++++++++++++++++++++++
>  This Mail Was Scanned By Mail-seCure System
>  at the Tel-Aviv University CC.

Reply to: