[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Newby can't get Xwindows running

As a complete novice to Linux, please bear with me if my explanation of the
problem is confused.

I installed Debian 3.0 r2 woody kernel 2.2.20 (many times on 2 different
machines) using defaults and keeping as simple as possible, but I have not
been able to get XWindows running.

I used taskel to select: XWindows, Desktop environment and C/C++ 

It boots into the bash shell fine except that during boot-up a message
appears: "Modprobe can't locate char-major-10-135"  (the pause key doesn't
halt the screen during boot-up so other important message might flash past
before I can write them down)

I have a Matrox MGA G200 - 16Mb
Phillips SL200 19" monitor
MS 2 button mouse on PS2 port

The problem is, when I try to run X, XFree386, xdm, kdm or gdm it does not
go to VGA mode but spews forth dialogue including the following lines which
seem significant:

"	Warning couldn't open module mga_hal
"	MGA: Failed to load module mga_hal (Module does not exist, 0)

"	EE Screen(s) found, but none have a usable configuration.

"	Fatal Server error no screens found

if I run xf86cfg, it goes to VGA mode and brings up the XWindows
configuration modules, but the mouse doesn't work.

I run xf86config and re-enter the hardware specs (to the best of my
ability), but this makes no difference.

I am basic level user with unix (some years ago), and without gui feel like
I have been thrown in the deep-end in a tied sack. If I had XWindows I could
probably start swimming.

David Moore

Reply to: