[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Starting x-apps from bash (or ssh)

 --- Sturla Holm Hansen <sturla@lundkommisjonen.no> wrote: 

> You are absolutely right, I was trying as root, while having X started 
> with my regular user, and it worked as that user....at least 
> locally...still not with ssh

In both cases, what you need to do is:

export DISPLAY=:0.0
xauth merge ~user/.Xauthority

(the user being the user running the X11 server as).

> But I haven't had that problem on redhat/fedora, what's different?
> And how do I export the DISPLAY-variable?
> And what about ssh?

As for ssh, you have two options:

1. You can use X11 forwarding with ssh (ssh -X)
2. You can login a user, and execute the steps above.

> Hmmm...I'm starting to sound like one of my users...sorry ;)
> Any hints would be greatly appreciated though.

I hope that helps,

-- Thomas Adam

"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 

Reply to: