[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound on Sarge

Katipo <katipo@weavers-web.org> wrote on Fri, 23 Apr 2004:-

>This looks like alsa-xmms predepends on xmms, which is hardly >surprising.
>Xmms has a myriad of these.
>If alsa-xmms didn't exist, your packet manager would say so, as in:-
>"alsa-xmms, no such package," quite emphatically.


>Not gospel, but it looks as though alsa-xmms is an integral part of the
>xmms package to the point where it is not recognised as a separate >entity.
>You may have to install xmms to get it. I can't think of any other
>reason as to why your package manager would respond by installing an
>apparently unrequested package otherwise.


In view of what you said, I decided to install 'xmms' (if necessary I
could always purge it).

The install log shows what the problem was:-

Version: 1.2.10-1
Replaces: x11ampg, x11amp, xmms-vorbis, alsa-xmms
Provides: mp3-decoder, x11ampg, x11amp, xmms-vorbis, alsa-xmms
Depends: libc6 (>= 2.3.2.ds1-4), libglib1.2 (>= 1.2.0), libgtk1.2 (>= 1.2.10-4), xlibs (>> 4.1.0) | libice6, xlibs (>> 4.1.0) | libsm6, xlibs (>> 4.1.0) | libx11-6, xlibs (>> 4.1.0) | libxext6, xlibs (>> 4.1.0) | libxi6 Recommends: libasound2 (>> 1.0.0), libaudiofile0 (>= 0.2.3-4), libesd0 (>= 0.2.29-1) | libesd-alsa0 (>= 0.2.29-1), libmikmod2 (>= 3.1.10), libogg0 (>= 1.1.0), libvorbis0a (>= 1.0.1), libvorbisfile3 (>= 1.0.1), xlibmesa3-gl | libgl1, zlib1g (>= 1:1.2.1)
Suggests: unzip
Conflicts: x11ampg, x11amp, xmms-vorbis, alsa-xmms

Again, thanks for pointing the way.

Regards,			John.

Reply to: