[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: new install, sound not working (+2 bonus problems)



On Thu, 22 Apr 2004 21:26:56 -0700 (PDT)
Phil Ramey <philramey@pacbell.net> wrote:
>
> 2) in first attempt to get sound working, i compiled a
> new kernel, 2.6.5, with ALSA, but the wrong drivers

sid + 2.6 kernel is pretty bold for a new user, to be blunt.  I don't
mean to dissuade you -- just that it's not surprising that this should
be hard.  Getting everything just so under the new 2.6 kernels has
given a lot of people a lot of difficulty, as numerous threads in
the archive here will show.  I haven't tried it yet, mainly because
I do audio work and the configuration of 2.6 kernels for optimum
realtime performance is still being figured out.

I've spent a lot of time messing with ALSA under the 2.4's,
but none under 2.6 (when it got packaged with the kernel);
I'm still not sure how it's different, but it apparently is,
so I'm not sure I'll be any help.  With that out of the way
. . .


> 3) incremented the "extra version" makefile option

Just out of curiosity . . .I'm not sure what you mean by this.
How are you compiling your kernels?  Also, you may want to take
a look at 

http://newbiedoc.sourceforge.net/system/kernel-pkg.html.en

which provides a good explanation of the relatively painless
way to do it in Debian, through use of the make-kpkg command.


> and
> re-compiled with the right drives and ALSA, no dice,
> still didn't work.  it detected the chip fine in boot,
> but didn't work.

When you did this, did you configure your kernel so that ALSA was
compiled into the kernel itself, or as separate modules?  What about
soundcore?  Did you only compile ALSA stuff, or did you also compile
OSS stuff as well as ALSA?  Are you sure about these answers?  Can
you show me the sound portions of the .config for this kernel?  And,
with this kernel booted, can you do an lsmod and show what modules
you have loaded?  Also, can you show me the messages from it
"detecting the chip fine in boot"?  And what do the ALSA portions
of your /etc/modules.conf look like?


> gnome's volume control gave me crap
> for not being able to open /dev/mixer so i addusered
> my user into the audio group, which made it quiet
> down.

Yeah, that's a common pitfall.


> Inexplicably, no sound application worked
> except for Stones, the gnome stones clone.  sound
> started a few seconds into the game, and was
> low-quality thoughout.

What about other GNOME applications that make sound?  If you go to
GNOME's menus, going Desktop Preferences --> Sound, and turn on
"sound events" for GNOME, do you hear sounds (assuming you have the
gnome-audio package installed, which provides the .wav files for
GNOME events)?  If you try to play a wav file from the command line,
using the "play" command, e.g.

play /usr/share/sounds/login.wav

what happens?  If it doesn't work, what error message do you see?
What if you do

esdplay /usr/share/sounds/login.wav

instead?


> Tried alsaconf, it didn't
> detect the chip.  alsaconf also gave error: "cannot
> find module SND" three times at run...

OK, this smells to me like you don't actually have ALSA installed;
an lsmod under this case would be handy, as noted above.  I know
that you built ALSA during your kernel compile because you say
you did above; but that doesn't mean that ALSA got loaded properly
at boot-time.

One possibility which trips people up fairly often is when they
compile modules for both ALSA and OSS, *and* have the discover
package installed.  discover is a hardware detection program that
loads modules on the basis of what it finds.  It runs before the
ALSA scripts do during a normal boot process, and when it finds
a soundcard, it *tries to load OSS drivers*.  Then, the ALSA
drivers can't load, because the OSS drivers are already in and
taking care of the soundcard.  I've heard tell that hotplug can
do this to you too, but I don't have any personal experience with
that.  Anyway, lsmod, and an examination of the boot log, as
requested above, should show if this is what's going on.  The
solution, if so, is to tell discover (or hotplug) to *not* load
OSS drivers through configuration files.


> 4) recompiled again with proper driver and OSS, boot
> detects the chip (integraded on the mobo,
> don't'cha'know), and stones works better (music this
> time), but nothing else is fixed.  when i load any
> multimedia program, it complains about not being able
> to open /dev/dsp

What's the complaint error message *specifically*?

A common problem that occurs in this instance, with you running
GNOME, has to do with esd.  GNOME uses a software daemon called
esd, the "Enlightened Sound Daemon," to mix together multiple
sound sources, so that you can hear multiple simultaneous sounds.
Unfortunately, esd can grab onto /dev/dsp and not let any other
software talk to it because it's busy.  One solution to this is
to dump esd.  Another is to adjust esd to let go of /dev/dsp when
it doesn't need it, which is done through its config file.


> I have two hard drives and two cdrom drives, and only
> one of each is currently recognised by the system.  my
> unrecognised HD has ~20gigs of mp3s and such that i'd
> like to keep if i can... it's fat32 (converted with
> partitionmagic from NTFS for compatability)... i have
> Vfat compiled in, but... i don't know what to do to
> get them in fstab, etc...

First off, you'll get a lot more answers to your questions if you put
them in different threads.  There are probably a fair number of people
who could help you with this who never read it, because they saw a
zillion lines about ALSA at the top of the post and moved on.  Give
your questions separate threads with informative subject lines.

Now, what do you mean by "only one of each is currently recognised
by the system"?  Do they show up in the BIOS?  If so, does the early
part of the boot detect them as being present?  Or is your problem
just that they're not mounted?  Before thinking about editing
fstab, can they be mounted at all?  What happens if you try to mount
them manually using the mount command?


> sort of related second side problem:  I have an iRiver
> iHP-120, 20gig hard-disk mp3/ogg/wma/etc player, that
> uses USB2.0 (or 1.1) mass storage... i installed all
> the kernel packages i could see though menuconfig that
> USB Mass Storage needed... but i don't really know
> where to go from there... there's USB1.1 on my mobo
> that works (my mouse!), and a USB2 PCI card that i've
> not confirmed works, yet.

This I can't help you with.  But, again, you might get more
answers if you put it in a separate message with a useful
subject line.

-c

-- 
Chris Metzler			cmetzler@speakeasy.snip-me.net
		(remove "snip-me." to email)

"As a child I understood how to give; I have forgotten this grace since I
have become civilized." - Chief Luther Standing Bear

Attachment: pgpFc4JP6pYX0.pgp
Description: PGP signature


Reply to: