[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with Xfree86 on Sarge

George Cristian Birzan wrote:

On Thu, Apr 22, 2004 at 01:00:56PM +0200, Daniel Altendorf wrote:
So I apt-get install'ed Gnome and xserver-xfree86 (xserver-common was included) and then configured it. No problems with configuration, no errors, nothing.
So I hammer "startx" into the keyboard and it gives me this:

/usr/X11R6/lib/X11/xinit/xserverrc: line 2: /usr/bin/X11/X: No such file or directory /usr/X11R6/lib/X11/xinit/xserverrc: line 2: exec: /usr/bin/X11/X: cannot execute: No such file or directory
giving up.
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): Server error.

Hm. Try apt-get install x-window-system. If not even that helps, try
apt-get --purge remove xserver-common xserver-xfree86
apt-get install xserver-common xserver-xfree86
I tried that and got the exact same error message.

Now I hope you guys can help me. I am relatively new to Linux (used SuSE and Debian before, but never really "got into it") and thus have absolutely NO idea what to do. I tried checking the files he states there for errors, but couldn't really get anywhere.

Are the files there?
I think that is where the problem lies. I just checked and I do not have an /usr/bin/X11/X directory.

Another problem is that I constantly have to boot from Debian to Win so I can google, because I currently have only one computer here.

apt-get install links surfraw, then "sr google whatnot" (Pfeh, they
moved stuff to /usr/lib/surfraw/, so you'll have to run
surfraw-update-path -add to be able to do just "google whatnot")
Thanks, I will try that one! ;-)

P.S.: Btw, with dpkg-reconfigure xserver-xfree86, what is the correct mouse /dev for a usb mouse?

Ah... I _THINK_ /dev/input/mouse, or something similar.


Reply to: