[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with Xfree86 on Sarge

Hello all!

Yesterday I decided to reactivate my Debian partition and install the current Sarge on it, so I can *finally* get away from Wintendo. The actual system installation, went perfectly well. No problems, just fine. System boots without any fuss.

Then, shortly after checking out the system a bit, I decided that I'd install Xfree86 and Gnome now, so I can work. On my last installation (Woody) this worked fine, even with the unstable Gnome2 packages that I had to get.

So I apt-get install'ed Gnome and xserver-xfree86 (xserver-common was included) and then configured it. No problems with configuration, no errors, nothing.
So I hammer "startx" into the keyboard and it gives me this:

/usr/X11R6/lib/X11/xinit/xserverrc: line 2: /usr/bin/X11/X: No such file or directory /usr/X11R6/lib/X11/xinit/xserverrc: line 2: exec: /usr/bin/X11/X: cannot execute: No such file or directory
giving up.
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): Server error.

Getting that, I googled a bit and found an incredible two people who share my problem. One is italian (and posted entirely in italian), the other one spoke a really bad english, but I understood from both their posts that they didn't manage to work this out.

Now I hope you guys can help me. I am relatively new to Linux (used SuSE and Debian before, but never really "got into it") and thus have absolutely NO idea what to do. I tried checking the files he states there for errors, but couldn't really get anywhere. Another problem is that I constantly have to boot from Debian to Win so I can google, because I currently have only one computer here.

Before I will posts lots and lots of (maybe useless to you) information, I will wait what you guys will need/request. :-)

Thanks a bunch!

P.S.: Btw, with dpkg-reconfigure xserver-xfree86, what is the correct mouse /dev for a usb mouse?

Reply to: