[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: serious apt error after aptitude catastrophe

Matt Price wrote:
gaah, forgot to add:  downgrading libc6 leads to terrible
system-breaking conflicts.

tried switching to aptitude and, while I was't looking, aptitude
started to uninstall a whole slew of fundamental packages from my
computer!  now I have to reinstall them, but the Sid glibc backage
seems to have aserious conflict with sysinit:
Note, selecting libc6 instead of glibc-2.3.2.ds1-11
Suggested packages:
1 packages upgraded, 0 newly installed, 0 to remove and 753 not
2 packages not fully installed or removed.
Need to get 0B/4211kB of archives.
After unpacking 20.5kB of additional disk space will be used.
(Reading database ... 136582 files and directories currently
Preparing to replace libc6 2.3.2.ds1-10 (using
../libc6_2.3.2.ds1-11_powerpc.deb) ...
Unpacking replacement libc6 ...
dpkg: error processing
/var/cache/apt/archives/libc6_2.3.2.ds1-11_powerpc.deb (--unpack):
trying to overwrite `/etc/default/devpts', which is also in package
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Is there a trick for getting around a fundamental conflict like this
one?  My system is pretty well disabled at the moment (e.g., I'm
missing "less" and can't install it!any clues?

So you can still run dpkg?

You can see that the package is located at /var/cache/apt/archives/libc6_2.3.2.sd1-11_powerpc.deb.

And that it is failing on the step '--unpack'.

Look in 'man dpkg' to understand what the --unpack step is.

Then look for the --force-<things> option to try to force it to install, if installing it is what you want to do.

But you say that you tried to downgrade libc6? Do you want to install this package, or are you trying to set it not to be installed?

Your system is definitely recoverable though, so don't worry.


Reply to: