[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound not working

Jaap Haitsma wrote:


Yesterday I installed Debian Unstable (hoping to become a very happy Debian user) by running the netinstaller and then selecting "desktop" in tasksel.

I had the problem that sound and volume control weren't working.

When I wanted to play an audio file it was complaining taht it cannot open /dev/dsp and the volume control applet complained that /dev/sound/mixer does not exist. (/dev/mixer exists)

I now got everything working by changing the file permission of
/dev/dsp and /dev/mixer from crw-rw---- to crw-rw-rw- (both are owned by root:audio) and make a symbolic link from /dev/sound/mixer to /dev/mixer

Nope; not what you want to do. Instead, add your user to the audio group, like so:
   adduser jaap audio

What I first tried is adding the audio group to my group but that didn't work.


After adding your user to the audio group, you'll need to logout and back in.

Still doesn't work?
1) Your sound chip is not properly supported by whatever kernel you're using,
2) You don't have the correct modules installed
3) You're running a desktop environment like KDE or Gnome which expects a sound daemon like artsd or esd, and that daemon is not running.
4) Profit?  (that's a "insiders" joke, if you don't get it)


Reply to: