[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Printing problems w/CUPS, HP 5550, WP8

Cage <cage47@vonl.com> wrote:

For WP8 to use cups printers you will have to make a printcap file in /etc. What I did was setup the printer in cups and verified it worked. Then I made a link (in konqueror I just copied the printcap.cups file back into /etc and made it a link) from printcap.cups and named it printcap. This is becuase WP was made before cups came out and looks for the printcap file.

Well, I made a link from /var/run/cups/printcap to /etc/printcap and that got Opera to print (which I noticed was not printing after my initial post), but WP8 is still not printing. It still thinks that it should be printing to my old printer even though that printer is not attatched to the system and is not in the current printcap file.

I also have questions about Firebird and Thunderbird. Initially, they were not printing, either. I think that they started to work after I ran kudzu and let it configure the printer. Firebird now has only one printer option "PostScript/default" and printing to that works just fine. Thunderbird also has the same "PostScript/default" and if I print to it everything works. The problem is that, although it appears that it should be the default, it isn't. There are several other options, "hpdeskjet5550@:64" (which is what does come up by default), "xp_ps_spooldir_tmp_Xprintjobs@:64", and "xp_pdf_spooldir_tmp_Xprintjobs@:64" are at the top of the printer list. Is there any way to get those first three not to show up, or, at least to get "PostScript/default" to actually be the default?

Marc Shapiro      "If you drink melomel every day you will live to be 150,
                   unless your wife shoots you first."
                   -- Dr. Ferenc Androci
                   -- (Winemaker, Little Hungary Farm Winery)

Reply to: