[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What makes /dev/hdb1 say it's mounted/active when it isn't?

On Tuesday 02 March 2004 18:01, Chris Evans wrote:
> On 2 Mar 2004 at 17:47, CW Harris wrote:
> > Shouldn't matter, as long as your BIOS can boot it (which it obviously
> > can).
> It can, but is there any possibility that's it's requiring the
> controller or HD to be "active" as far as the kernel is concerned?  I
> can't see how that's the case but my grasp of the mbr and partitions
> has always been shakey.
> > >   mdadm --create /dev/md0 --level=1 --raid-disks=2 missing /dev/hdc1
> >
> >                                    ^ ^ ^ ^ ^ ^ ^
> > Okay, I haven't used the mdadm (I used raidtools2), but shouldn't this
> > be hdb1 missing?
> I don't think so, it's straight out of that howto (I pretty sure).  I
> think it is reserving a first disc, unspecified, as failed, in a two
> disc array in which the second disc is active and is /dev/hdc1
> I've tried using /etc/raidtab setting up essentially the raid1 config
> that's supplied but tweaking to /dev/hdb1 and /dev/hdc1 and ending
> with a failed-disk line:
> # Sample raid-1 configuration
> raiddev                 /dev/md0
> raid-level              1
> nr-raid-disks           2
> nr-spare-disks          0
> chunk-size              4
> device                  /dev/hdc1
> raid-disk               0
> device                  /dev/hdb1
> raid-disk               1
> failed-disk             1
> and that has the same result (I think the /etc/raidtab is spurious
> since, as I understand it, this is actually stored in the persistent
> superblock??)
I believe this file is spurious for mdadm, but not for raidtools2.  
Regardless, it can't hurt to have it, and yours looks fine.

> > > which worked fine, mkfs -t ext3 /dev/hdc1, mount it to /mnt1,
> >
> > and then shouldn't you have a working /dev/md0 to mkfs -t ext3
> > /dev/md0?
> Sorry, me being stupid in what I wrote, indeed so.   I was getting a
> working degraded array with one working drive and it was that I
> formatted. Sorry.
> > If above was incorrect, then hdb1 would be part of the (active) RAID?
> > so you can't import it again.
> cat /proc/mdstat doesn't show it as active:
> cat /proc/mdstat
> Personalities : [raid1]
> read_ahead 1024 sectors
> md0 : active raid1 hdc1[1]
>       78124928 blocks [2/1] [_U]
> unused devices: <none>
> I read that as sayng that it's a degraded array currently with just
> the one drive in it, /dev/hdc1, and with space for a second.
Correct.  This looks like it's ready to add the other disk.

> > I haven't done that much RAID, and not with mdadm.  But if my comments
> > above are correct, maybe this is your problem?
> Much thanks, and I'm happy to be corrected, but I think they're not
> the problem though one of them was a typo of mine in the Email,
> fdsk'ing the raw drive not the array, that several people have noted.
> _ANY_ suggestions welcome: it feels so lame to just use that second
> drive to mirror the first with a regular cp -aux / /mnt2 or something
> like that, though I'm starting to think that's the time efficient
> option given how much time setting up this server has cost me!
The initial complaint that /dev/hdb1 was active tells me that you might have 
been booting off that drive, and not your raid array.  What does lilo.conf 
look like when you boot off the raid, but can't add /dev/hdb1?  Either post 
that here or to the other response.  No need to do both.

> Cheers all,
> C
> PSYCTC: Psychotherapy, Psychology, Psychiatry, Counselling
>    and Therapeutic Communities; practice, research,
>    teaching and consultancy.
> Chris Evans & Jo-anne Carlyle
> http://psyctc.org/ Email: chris@psyctc.org

Justin Guerin

Reply to: