[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

easy way to install sid by ftp?

I've seen loads of questions about how to install debian, and always thought 
it can't be that difficult"... I was wrong.  

My previous two installations were by transfering Knoppix to the hd and 
changing sources.list to use sid sources only and then upgrading.  It leaves 
permanent Knoppix splash screens and all sorts of other bits in menu 
structures and filesystems, most of which I have left alone for the sake of 
safety.  Over time I keep purging things I do not really need (whenever the 
depends don't stop me, that is). It is not bad, but it is messy.

 I would like to simply install sid with a basic system and add the 
applications I want.  Is there no easy way to do this?

I am trying to put sid on a thinkpad 600E. I have failed with the 1G install 
CD downloaded from debian.org.  I also fail with running debootstrap direct 
from ftp, as described on www.uk.debian.org. Below are brief details, but not 
very informative, I fear.  I am quite happy to wipe it and start again if 
anyone can suggest a straightforward way of getting sid on the machine.

FWIW, what I tried was as follows.  It is long so please skip it unless you 
have done this and might have an insight. 

I downloaded and burned the 1G minimum CD for sarge, thinking to install that 
and dist-upgrade.  The installer sort-of works - but with a number of red 
screen errors (something about scsi-ide not being available yet, although my 
s/h thinkpad has no scsi interface that I know of).  All the errors suggested 
looking at /target/var/log/debootstrap.log and debootstrap.error.log, both of 
which remained empty.

Network interface card, a Billionton LNA-100B or the Sitecom rebranded version 
of the same as sold by Maplins) seemed to be working (I could ping the 
machine from elsewhere). I could not ping out, so I added the stanza 
to /etc/pcmcia/config as instructed by the maker, and tried 
to /etc/init.d/pcmcia restart, but got an error: "No socket drivers", 
whatever that means.  Anyway I rebooted as the install script seemed to have 
nothing else to offer and the new installation started but with no network at 
all.  It came up with strange double-height console text for some reason. 

Then I re-inserted the 1GB install disk, and rebooted to try again.  This time 
I tried the simple "linux" rather than "expert" route.  The process ran 
mostly unaided - apart from needing network configuration (mine is static IPs 
not DHCP). After retrieving a long list of items it gave a blue screen (not 
_that_ blue screen...) for a while and then exited with "debootstrap program 
exited with error..." and /target/var/log/debootstrap.log now showed 
"/target/usr/bin/awk: file exists" (nothing else). --error.log still empty.

As the system was running, and I could manually start networking, I copied the 
kernel and boot stuff, and the networking stuff all from target to the root 
filesystem, intending to run lilo and see what happens on reboot.  Lilo 
 "warning: '/proc/partitions' does not match '/dev' directory structure.  
 Name change '/dev/ide/host0/bus0/target0/lun0/disc' -> '/dev/hda'"
I was puzzled by these strange long names in place of the /dev/hda when 
partitioning.  No idea why that happened.

Before actually rebooting, while it was running with a working network, I 
thought to try the instructions given at uk.debian.org, and ran 
"/usr/bin/debootstrap --arch i386 sid /mnt/debinst \

This seemed to run well.  It retrieved and validated a long list of basic 
stuff, then began extracting them. the 18th file it tried to extract was 
e2fsprogs, and there it halted with "tar: unrecognised file type"

There seems to be no way round that sort of problem for a simple user like me, 
so I went back to trying to boot the system as partially set up before.  This 
boots, again in the useles double-height font, but thinks eth0 does not 
exist, so I cannot configure networking to continue downloading. 

At this point, I am out of skills and ideas, so ready to try any organised 

It seems that Knoppix is the only way to install, unless anyone can point me 
at a better one.  I had considered the chroot method, but as I always lose 
networking on any reboot from whatever basic install, I can't see how that 
can be made work, even if I can understand it.

TIA (and apologies for length)


Reply to: