[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: modules after kernel make - can't get new kernel finding its modules

On 1 Mar 2004 at 18:27, Martin Wood wrote:

> I think this is exactly where i went wrong the other day.
> try adding :
> make modules
> make modules_install
> and hopefully your modules will show up

Thanks Martin.  I should have said that I've tried this sequence with 
and without that, make modules and make modules_install both produce 
a lot of moving in and out of subdirectories:

make -C  arch/i386/lib modules_install
make[1]: Entering directory `/usr/src/kernel-source-
make[1]: Nothing to be done for `modules_install'.

but that "Nothing to be done" message seems to be summarising the 

I think they aren't doing more than the make dep make-kpkg clean make-
kpkg --rev ... kernel_image sequence is doing.  

I think that all of them are simply assuming either I have the 
necessary modules already or that there are far fewer modules I want 
than I atually do want.

Anyone any idea what's wrong and how I can perhaps restart the whole 
sequence and insist that all the modules get compiled and installed?

TIA (and thanks again Martin: funny how down I get failing on these 
things, feeling stupid, _and_ getting no answers!)

PSYCTC: Psychotherapy, Psychology, Psychiatry, Counselling
   and Therapeutic Communities; practice, research, 
   teaching and consultancy.
Chris Evans & Jo-anne Carlyle
http://psyctc.org/ Email: chris@psyctc.org

Reply to: