[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Power management with 2.4 kernel

I was able to use power management on my desktop with kernel 2.4.22 but
once I upgraded to another 2.4.X kernel I started having problems. The
desktop would go into power-saving mode but would not wake up no matter
what I tried.

I installed Debian from the beta 2 installer, and am running unstable:

"Linux 2.4.25-1-686 #1 Tue Feb 24 10:55:59 EST 2004 GNU/Linux"

With kernel 2.4.22 I enabled power management in the BIOS and placed
"apm" in /etc/modules. Everything worked fine. But once I upgraded the
"obsolete" kernel, the machine would drop into the power-saving mode but
not wake up. I would move the mouse, hit the keyboard, and get nothing.
The only thing I could do was reboot the machine with the reset button.
This happened whether I had "apm" in /etc/modules or not. (That is, in
both instances power-saving was turned on in the BIOS.)

Here is some ACPI-related dmesg output:

 BIOS-e820: 00000000040fdc00 - 00000000040ff800 (ACPI data)
 BIOS-e820: 00000000040ff800 - 00000000040ffc00 (ACPI NVS)
ACPI: have wakeup address 0xc0001000
ACPI disabled because your bios is from 99 and too old
You can enable it with acpi=force
ACPI: Subsystem revision 20040116
ACPI: Interpreter disabled.
PCI: ACPI tables contain no PCI IRQ routing entries

Any ideas? Thanks.

Reply to: