[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Software RAID problems (bad filesystem type)

On Monday 09 February 2004 10:16, Timo Railo wrote:
> Hi David,
> thank you for your reply!
> I've tried putting it to /etc/fstab, but getting the error on boot
> time. And since it's remote computer, it's a little inconvenient cause
> it won't continue the bootup process without keyboard input. Here is my
> fstab setup:
You should use the option "noauto" instead of "defaults" while you're 
debugging it.  That way, it won't try to mount on boot up.  It will only 
try to mount when you ask specifically.

> /dev/hda1       /               ext3    errors=remount-ro       0      
> 1
> /dev/hda2       none            swap    sw                      0      
> 0
> /dev/hda3       /mnt/hda3       ext3    defaults                0      
> 2
> /dev/md0        /mnt/md0        ext3    defaults                0      
> 0 (this commented out for boot)
> proc            /proc           proc    defaults                0      
> 0
> /dev/fd0        /floppy         auto    user,noauto             0      
> 0
> /dev/cdrom      /cdrom          iso9660 ro,user,noauto          0      
> 0
> When I build the raid with mdadm --create, do mkfs.ext3 and then do
> mount (with or without -t, doesn't matter) it mounts beautifully. When
> I reboot, uncomment the device in fstab and do mount -a or just try
> mounting it via mount -t ext3 /dev/md0 /mnt/md0 it gives the error.
> I've also tried doing "dd if=/dev/zero of=/dev/hdc" to make it clean.
> When doing e2fsck /dev/hdc1 I get this error:
> e2fsck 1.35-WIP (07-Dec-2003)
> e2fsck: Invalid argument while trying to open /dev/hdc1
> The superblock could not be read or does not describe a correct ext2
> filesystem.  If the device is valid and it really contains an ext2
> filesystem (and not swap or ufs or something else), then the superblock
> is corrupt, and you might try running e2fsck with an alternate
> superblock:
>      e2fsck -b 8193 <device>
> Many thanks for any input!!
> Timo

I see from your fstab that you're not trying to boot off the raid device.  
My previous advice was for that situation.  Sorry if it caused confusion.

Your fstab file for your raid device is correct.  What does your /etc/
raidtab and /etc/raid/raidtab look like?  /etc/raidtab should be a link 
to /etc/raid/raidtab.  Post the contents of /etc/raid/raidtab, and we may 
be more able to pinpoint your problem.

Also, provide the output of "cat /proc/mdstat".  You should see something 
like this:
Personalities : [raid1]
read_ahead 1024 sectors
md0 : active raid1 hdc1[1] hda2[0]
      15936 blocks [2/2] [UU]

If you don't, it means your raid drivers haven't been properly initialized 
and pointed to your raid disks.

Justin Guerin

Reply to: