[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apache won't start although no errors



On Sat, 07 Feb 2004 10:54:31 -0500
Kevin Coyner <kevin@rustybear.com> wrote:

> 
> This one is weird.
> 
> I'm running apache 1.3, and just did a restart, and it won't come up.
> 
> When I execute 'apachectl start' I get:
> 
> root@server1:$ apachectl start
> Processing config directory: /etc/apache/conf.d
> Processing config file: /etc/apache/conf.d/phpmyadmin
> 
> Which is pretty normal.

The "Debian method" for doing this is "/etc/init.d/apache restart". Have
you tried this yet?
 
> But when I check to see if it's running, it's not.  No PID.  Nothing.

What command are you using to see if Apache is running? What makes you
say it's not running?

> When I execute 'apachectl configtest' I get:
> 
> root@server1:$ apachectl configtest
> Processing config directory: /etc/apache/conf.d
> Processing config file: /etc/apache/conf.d/phpmyadmin
> Syntax OK
> 
> So my httpd.conf file is just fine.
> 
> /var/log/apache/error.log doesn't give any clues.
> 
> What am I missing?  In a bit of a panic here ...

Have you tried going to http://your.ip.add.ress/ to see if it's running
or not?

Was Apache installed through apt-get or did you compile from source?
What version of Debian are you running?

Jacob

----- 
GnuPG Key: 1024D/16377135

Windows, the yo-yo operating system; it goes up... it goes down... it
goes up...

Attachment: pgpvl02JzFozE.pgp
Description: PGP signature


Reply to: