[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fw: aespipe & encrypted cdroms, not working



Begin forwarded message:

Date: Tue, 27 Jan 2004 18:08:40 -0800
From: "Rodney D. Myers" <rdmyers@pe.net>
To: Debian User List <debian-user@lists.debian.org>
Subject: aespipe & encrypted cdroms, not working


I'm trying to get aes to encrypt a cdrom, using the following;


yes "" | dd of=test.iso bs=512 count=16

head -c 2880 /dev/random | uuencode -m - | head -n 65 | tail -n 64 | gpg --symmetric -a | dd of=test.iso  conv=notrunc

mkisofs -r /home/rodney/multimedia-graphics/specialty | aespipe -w 10 -K test.iso -O 16 >>test.iso

When this is done, it appears to have created a valid iso image,
but...

But when I attempt to mount this iso image, with the following, I keep
receiving an error message; [ correct error message below ]

sudo mount -t iso9660 test.iso /cdrom -o loop=/dev/loop0,encryption=AES128,gpgkey=test.iso,offset=8192

Password:
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
       or too many mounted file systems


I have no idea as to qhat could be wrong. 

Any tips and/or suggestions would be greatly appreciated

Thanks

-- 
Rodney D. Myers <rdmyers@pe.net>	Registered Linux User #96112
ICQ#:     AIM#:       YAHOO:
18002350  mailman452  mailman42_5

They that can give up essential liberty to obtain a 
little temporary safety deserve neither liberty nor safety.
        Ben Franklin - 1759



-- 
Rodney D. Myers <rdmyers@pe.net>	Registered Linux User #96112
ICQ#:     AIM#:       YAHOO:
18002350  mailman452  mailman42_5

They that can give up essential liberty to obtain a 
little temporary safety deserve neither liberty nor safety.
        Ben Franklin - 1759

Attachment: pgpKNqMaZAqZj.pgp
Description: PGP signature


Reply to: