[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ALSA, kernel 2.4.24-1-686 and intel AC'97 sound card

Have successfully got ALSA running on my -k7 with an ensoniq 1371 by
following the instructions here


And by following the info under the "Stock Debian kernel without
precompiled modules" section. Only difference was that it was also
necessary to install alsa-base and alsa-utils - just prior to
installing the build alsa-module deb.

So - I've just tried the same on this -1-686 with

00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio Controller (rev 02)

Searching alsa-project seems to imply that you need the intel8x0
driver - at least
http://www.alsa-project.org/alsa/driver-source/pci/intel8x0m.c shows
the 82180CA card although the soundcard search on the alsa pages does

Built the module, installed it and rebooted.

lsmod gives for sound modules:

snd-seq-oss            29632   0 (unused)
snd-seq-midi-event      3264   0 [snd-seq-oss]
snd-seq                36624   2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss            39172   0 (unused)
snd-mixer-oss          13392   0 [snd-pcm-oss]
snd-intel8x0           19400   2
snd-ac97-codec         48556   0 [snd-intel8x0]
snd-pcm                61476   2 [snd-pcm-oss snd-intel8x0]
snd-timer              14500   0 [snd-seq snd-pcm]
snd-page-alloc          6324   0 [snd-intel8x0 snd-pcm]
gameport                1676   0 [snd-intel8x0]
snd-mpu401-uart         3328   0 [snd-intel8x0]
snd-rawmidi            13472   0 [snd-mpu401-uart]
snd-seq-device          4192   0 [snd-seq-oss snd-seq snd-rawmidi]
snd                    33252   0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
audio                  43352   0 (unused)
soundcore               3940   5 [snd audio]

And at boot time I get the messages:

intel8x0: clocking to 48000
ALSA mixer_oss.c:1224: unable to register OSS mixer device 0:0
ALSA pcm_oss.c:2376: unable to register OSS PCM device 0:0

Google for ALSA "unable to register OSS PCM" gives hits for the 2.6
kernel but not the 2.4.

Anyone got ALSA running for this sound card?

Chris Searle

Reply to: