[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't install Debian on HDD w/Promise controller card

Boudewijn wrote:

George Adams wrote:

I'm sure this must be a FAQ, but I can't seem to find anything helpful
googling for the answer.

I'm trying to install Debian woody (3.0r2) onto a new hard drive (WD1800JB, 180Gig Western Digital) in a new computer. It is the only hard drive in the
machine, and the only other IDE device is DVD+R drive.

My understanding of how the computer (BIOS, OS, etc.) interact with a large
(>137Gig) hard drive is a bit shaky, but I decided to try connecting the
drive directly to the motherboard's (ABIT IS7) IDE connector and booting off
a Debian CD. No dice - the installer saw the hard drive as /dev/hda, but
the partitioning program only saw 137Gig.

So I installed the Promise Ultra100TX controller card that Western Digital ships with the drive, connected the drive to it, and tried again. The BIOS sees the drive fine, but the Debian installer always gets to a point where
it tells me that it can't find any hard drives and I'm going to have to
insert a floppy with drivers if I want to continue any further. This
happens whether I use the "idepci" "bf24" or "compact" boot methods.

Neither WD or Promise appear to have any Linux drivers I can use. So, how do I get Debian to see the drive on the Promise controller and proceed with
the installation?

Thanks very much to anyone who can help!

Take advantage of our best MSN Dial-up offer of the year — six months @$9.95/month. Sign up now! http://join.msn.com/?page=dept/dialup

Hello George,

this sounds like a bios (or motherboard) problem.
I thought, after the bootstrap, the disk is adressed by linux, rather then by the bios. As opposed to DOS/Windows.

I have a 180 GB hdb working with no problems on a DELL 700 MHz P4.

Also a 66 MHz IBM Aptiva, which saw only 525 MB under W 3.11/bios. ca 1994.
Linux kernel 2.0 ca 1996 saw the full 550 MB the typenumber indicated.
An added 10 GB worked in no way with W 3.11, not as C:, not as D:
In linux the 10 GB would not work as hda (because the bios refused to bootstrap)
But it does work with the original 550 MB as hda, and the 10 GB as hdb.
This is the very reason I changed my attitude from linux as experimental to linux instead of Wintendo.
This saved my disk investment, still working today as fileserver.

Workaround maybe several partitions. If need be, made with Partition Magic in another machine.
Workaround maybe using a bios compatible hda for you too.
Perhaps you can boot(strap) from a floppy, then see the drive. I did not try or need this. Solution, or at least more info may be in the large-disk, and/or the from-boot-to-prompt faqs.

mvg Boudewijn

PS I was boasting, the Dell was 700 MHzP3.
And do try how knoppix sees your drives! Seems a little effort experiment.

Reply to: