[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: newbie: more startup problems

Lucas Bergman wrote:

Paul Schwartz <brpms@earthlink.net> writes:

Lucas Bergman <lucas@fivesight.com> writes:

Paul Schwartz <brpms@earthlink.net> writes:

Earlier I have written about not being able to find the agpgart
module [I can't start X]
Okay.  Is this still a problem?
Yes, it is.  Browsing through the Contents on CD #2, I find that
agpgart.o is supposed to be part of the base kernel.  I can't find
it in my installation.

I've been in the habit of making my own kernel these days, so I admit
I have no idea what comes with the standard one.

I have been trying to enable web access to update apt, etc.  I
have tried two ways: wvdial and pon...  Both seem to connect to
my ISP and establish ppp, but none of the programs I run are
able to communicate with the outside.
What do 'ifconfig' and 'cat /etc/resolv.conf' and 'netstat -rn'
say after you've connected?
ifconfig gives...
[ ... ]
ppp0 Link encap:Point-to-Point Protocol inet addr: P-t-P: Mask:

That line says that your IP address is and the IP
address of the server end of the PPP connection is  Keep
that in mind.

/etc/resolv.conf is

Seems okay, I guess.

and netstat -rn gives
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window
irtt Iface UH        0 0 0 ppp0 UH        0 0 0 sl0   U         0 0 0 eth0         UG        0 0 0 eth0         U         0 0 0 sl0

Ding!  This (the second-to-last line) says that your default traffic
is going through eth0, not ppp0.

 # route del default
 # route add default gw

This worked! DNS is working and I can ping lots of places [not all; don't know what that means]

pppconfig put a default parameter in the ISP file, but it doesn't seem to be taking charge.

I am doing apt-get update as I write, so this is progress.

Paul Schwartz

Reply to: