[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

My fonts in X has disappeared


I was using the Debian Woody and everything was working. Then, I was
upgraded to Sarge (apt-get dist-upgrade) and now I have one strange
problem: the most part of my fonts, in the X environment, has disappeared.
For example, in KDE, if I select "Appearance & Themes" - "Fonts" -
"Choose", there are only fonts like Courier 10 Pitch, Nimbus Mono L, etc.
Fonts like Helvetica (default of the system) was desappeared. I tried to
uninstall font packages, the XFree86, change the order of load in
/etc/X11/XF86Config-4, etc, but anything has worked.
My /etc/X11/XF86Config-4:
Section "Files"
        FontPath        "unix/:7100"                    # local font server
        # if the local font server has problems, we can fall back on these
        FontPath        "/usr/lib/X11/fonts/Type1"
        FontPath        "/usr/lib/X11/fonts/CID"
        FontPath        "/usr/lib/X11/fonts/Speedo"
        FontPath        "/usr/lib/X11/fonts/misc"
        FontPath        "/usr/lib/X11/fonts/cyrillic"
#       FontPath        "/usr/lib/X11/fonts/100dpi"
        FontPath        "/usr/lib/X11/fonts/75dpi"

Section "Module"
        Load    "GLcore"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "speedo"
        Load    "type1"
        Load    "vbe"

My /etc/X11/XftConfig:
# $XFree86: xc/lib/Xft/XftConfig.cpp,v 1.8 2001/11/21 23:41:12 keithp Exp $

dir "/usr/X11R6/lib/X11/fonts/Type1"
#dir "/usr/X11R6/lib/X11/fonts/100dpi"
dir "/usr/X11R6/lib/X11/fonts/75dpi"
dir "/usr/X11R6/lib/X11/fonts/misc"
dir "/usr/X11R6/lib/X11/fonts/encodings"
dir "/usr/X11R6/lib/X11/fonts/utils"

# alias 'fixed' for 'mono'
match any family == "fixed"             edit family =+ "mono";

# Check users config file
includeif       "~/.xftconfig"

# Alias between XLFD families and font file family name, prefer local
# fonts
match any family == "charter"           edit family += "bitstream charter";
match any family == "bitstream charter" edit family =+ "charter";
$ dpkg -l | grep font
ii  console-data   2002.12.04dbs- Keymaps, fonts, charset maps, fallback
ii  console-tools  0.2.3dbs-44    Linux console and font utilities
ii  defoma         0.11.5         Debian Font Manager -- automatic font
ii  fontconfig     2.2.1-8        generic font configuration library
ii  fttools        1.2-13.1       FreeType font utilities.
ii  gsfonts        6.0-2.1        Fonts for the ghostscript interpreter
ii  gsfonts-x11    0.17           Make Ghostscript fonts available to X11
ii  libconsole     0.2.3dbs-44    Shared libraries for Linux console and
ii  libfontconfig1 2.2.1-8        generic font configuration library
(shared l
ii  libfreetype6   2.1.7-1        FreeType 2 font engine, shared library
ii  libxft2        2.1.2-5        FreeType-based font drawing library for X
ii  psfontmgr      0.11.5         PostScript font manager -- part of
Defoma, D
ii  t1lib1         1.3.1-3        Type 1 font rasterizer library - runtime
ii  type1inst      0.6.1-3.1      Install Adobe Type 1 fonts into X11 and
ii  x-ttcidfont-co 14             Configure TrueType and CID fonts for X
rc  xfonts-100dpi  4.2.1-12.1     100 dpi fonts for X
ii  xfonts-75dpi   4.2.1-12.1     75 dpi fonts for X
ii  xfonts-abi     1.0.2+cvs.2002 Some fonts shipped with AbiWord
ii  xfonts-base    4.2.1-12.1     standard fonts for X
ii  xfonts-konsole 3.1.3-1        Fonts used by the KDE Konsole
ii  xfonts-scalabl 4.2.1-12.1     scalable fonts for X
ii  xfs            4.2.1-12.1     X font server
ii  xfs-xtt        1.4.1.xf430-3  X-TrueType font server

I really don´t know what I can make now. Please, can anyone help me?

Thanks in advance

Reply to: