[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: File system error (power outage)

hi ya francisco 

if it gives you that "WARNING" ... do NOT e2fsck a mounted filesystem

what you probably need to do ...
	assuming you have the following partitions

	/dev/hda1	/
	/dev/hda2	/tmp
	/dev/hda3	/var
	/dev/hda5	/usr
	/dev/hda6	/home

when it comes up and asking/telling you to run fsck manually
	- you should answer "y" to any questions it ask
	unless you know how to fix it without the e2fsck ap

	- if you get too many (hundreds) errors on sequential inodes
	than that partition is toast ... re-format it and restore from

# there is no guarantee that this will fix the problem but
# you dont have much choice ..
#	these same problems (semi-corrupted disk) will occur if you 
#	hit the power or reset switches ( not just from power outage )

--- to fix things up:

- NOTE ... fix / last  ( and do it after mounting it "read-only"
  NOTE ... do NOT e2fsck the swap partitions

- fix /tmp
	root# e2fsck /dev/hda2

- fix /var
	root# e2fsck /dev/hda3

- fix /usr
	root# e2fsck /dev/hda5

- fix /home
	root# e2fsck /dev/hda6

- now fix /	-- Important to use the right -o options

	root# mount -o ro,remount /dev/hda1 /
	root# e2fsck /dev/hda

-- reboot and you should be happy camper

c ya

On Tue, 9 Dec 2003, Francisco Castellon wrote:

> Hello:
> sometime last night my power must have gone off and back on again, I
> came to my computer today in the morning to find it saying:
> /dev/hda3: UNEXPECTED INCONSISTENCY; run fsck manually
>              (i.e., without -a or -p options)
> fsck failed. Please repair manually and reboot. Please note that the
> root file system is currently mounted read only. To remount it
> read-write:
> # mount -n -o remount, rw /
> CONTROL -D will exit from this shell and reboot the system.
> So what am I supposed to do now? I really dont have any critical
> information in the computer and I wouldn't mind reinstalling again,
> however there are about 5 files that I would like to keep. What exactly
> am I supposed to do with "e2fsck"? what command should I run? is it
> possible to fix this and not have to reinstall? I ran the command:
> "mount -n -o remount, rw /" and then I got this message:
> warning: mounting unchecked fs, running e2fsck is recommended.
> so then I ran "e2fsck /" and I got this message:
> WARNING!!! running e2fsck on a mounted filesystem may cause SEVERE
> filesystem damage.
> do you want to continue [y/n]: 
> So I typed no for now. what should I do at this point? what commands can
> I run? I would appreciatte any help you can give me. Thanx!
> -- 
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: